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Introduction

About This Manual
Intended use

This manual is intended as a help for the system designer to get started with the creation of
a configuration. It contains the following information:
•=

An introduction to the system and its components (Chapter 1)

•=

Descriptions of the key object types and terminology used in IGSS32 (Chapter 2)

•=

Step-by-step procedures for creating a configuration from scratch (Chapter 3)

The manual deals almost exclusively with Definition. For information about the other
programs in the IGSS32 system, refer to the Help function.
The manual is NOT a reference manual. The built-in Help function should be used for
finding further details about the topics covered in this manual. References to the Help
function are given throughout the manual.
Structure of this
manual

This manual contains the following chapters:

This chapter …

contains the following:

1: Welcome to
IGSS32

an introduction to IGSS32 and an overview of its components.

2 : Types and
Templates

definition and use of each of the IGSS types: area, diagram, graph,
analog, table, counter, digital, string and scaling, including an
explanation of the physical counterpart of each type. The chapter
gives you a thorough understanding of the different object types and
provides you with the terminology required for reading Chapter 3.

3: Creating a
Configuration

step-by-step procedures for creating a configuration. The sample
configuration is very small and simple but all the system types are
represented.

You will find the “IGSS32 Installation Guide” as a separate item in the software package.

1
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The following typographical conventions are used:
Item

Convention

Example

User interface element

Bold typeface

The Edit Mapping tab.

Menu structure

Arrow between menu items

To access Help, select Help
→ Help Topics.

User input

Monospace typeface

We have now inserted the
following text:
The level in the
basin is too low.
Pour faster …

Reference to Help

Italic typeface

For further details about
addressing, search for “PLC
addresses” in the Definition
Help file.

IGSS32 User Documentation
Documentation
overview

With the IGSS32 system you receive the following documentation items:
This documentation
item …

includes the following …

Getting Started

See the “About This Manual” section.
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IGSS Global Help

Help on functions and features common to the entire IGSS32
system and help for the IGSS32 Starter program.

IGSS32 Program Help

Step-by-step procedures, reference information and contextsensitive help for the specific program you are currently
working with.

Introduction
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Help

The figure below shows a typical window from the IGSS32 Help system:

Figure 1 A typical window from the IGSS32 Help system..

Types of Help
topics

We have tried to design our Help so that you can easily distinguish the different types of
information being presented. The most important types are:
Topic Type

Description

Step-by-step procedure

Includes numbered steps for performing a specific task. This
type of topic is presented in a small card-like window in the
upper right corner of the screen so that you can read the
procedure and perform the task at hand at the same time.

Reference information

Describes user interface details or conceptual information. For
example, there are topics describing the different object types.

What’s This? Help

Describes an individual item in a dialogue, that is a button or a
field.

3
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There are several ways to access Help dependent on what type of Help you want:
To access this type of Help … do the following…
Step-by-step procedure or
reference information

Select Help → Help Topics and find the requested topic
on the Contents tab or search for it from the Index or
Find tabs (see “Searching in Help” below).

What’s This? Help

In a dialogue, do one of the following:
in the upper right corner, then click the
•= Click the
item you want information about.
•= Move the focus to the desired item by pressing TAB,
then press F1.

Searching in Help Most often you will search for a specific piece of information in Help. The easiest way to

do this is by using the built-in search facilities:
Use the …

when you are searching for …

Index

Step-by-step procedures, reference or conceptual information or user
interface details.

Find

Specific words or phrases that you cannot find in the Index.

The Help function also contains a Contents tab which provides a hierarchical view of the
Help topics.
Help on Help

If you are in doubt as to how to use the Help function, just press F1 to get Help.

Updated Help files New updated Help files will be available for download on our Web site on www.7t.dk.

Click the IGSS logo to go to the IGSS Web site. Under "Support", select "IGSS32 v3
Support" and then click "Help Downloads".

When you have downloaded an update, you must run the *.exe file which will guide you
through the process of installing the Help files. You can update the Help files
independently of the system files, the context-sensitive Help will still work. In each Help
file you will find a Version topic in the Reference book on the Contents tab. That topic
tells you when the Help file was created and which software version it describes.
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Chapter 1: Welcome to IGSS32
Overview
About this
chapter

This chapter gives you an introduction to the IGSS32 system.

Contents

This chapter contains the following topics.
What is IGSS32? .................................................................................................................... 5
Overview of programs........................................................................................................... 6

What is IGSS32?
Introduction

IGSS is a SCADA system used for surveillance and control of industrial processes. Used in
a wide range of industrial applications including ship automation, water supply, food and
beverage and railway safety, IGSS has sold more than 20,000 licenses since first coming on
the market in 1984.
IGSS32 v3 runs under Windows 2000 and Windows NT 4.0.

User types

The system targets two types of users:
•= system designers who construct a model of the industrial plant and
•= operators who monitor and control the plant via PCs

Object-orientation IGSS32 is a true object-oriented program. This results in several useful advantages for the

system designer and the operator. Most importantly, a process component consisting of a
number of I/O points is treated as one object in IGSS32. This means that the system
designer and the operator have the same perception of an object and that the properties of
this object can be viewed and modified from one screen dialogue. Types and templates are
other object-oriented terms used in IGSS32. Templates are especially useful to the system
designer in that he can define one template and then base any number of objects sharing
identical properties on that template.

Chapter 1: Welcome to IGSS
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Data exchange
interfaces

Openness is a cornerstone in the IGSS32 architecture. 7-Technologies believes that our
users want the freedom to use the newest technologies. Therefore IGSS32 supports a variety
of standards and interfaces including DDE, ODBC, OPC, OLE Automation and ActiveX.
These interfaces allow you to exchange IGSS32 data with 3rd party programs. If you are
about to create a huge configuration, you may want to define the process components in an
external database and then import the data into IGSS32.

Scalability

Scalability is another key feature of IGSS32. Based on a true client/server architecture, you
can easily expand the number of operator stations or the number of objects in your
configuration. If you have a distributed plant, you can even connect remote operator
stations, if required.

Further details

For a more detailed overview of system features, search for "key features and benefits" in
the Global Help file.

What's new in in
this version

For an overview of the new features in this version, search for "what's new in this version
?" in the Global Help file.

Sales versions

When you buy IGSS32, you only purchase the number of objects and operator stations that
you need. The system can be expanded at any time as your needs grow.
Several redundancy solutions are also available to minimize system downtime. Please
contact our Sales Department for further information.

Overview of programs
Introduction

IGSS32 consists of a number of programs each with its own specific purpose. The following
list of programs is divided into the two main user types: System designers and operators.
Some programs are not part of the standard version. In that case, it is noted against the
program name.
For further details about any of the programs, use its associated Help function.

Chapter 1: Welcome to IGSS
System designer
programs

Program name

Summary of use
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Program type
Main program

Definition

Build a model of the physical process being
monitored and connect to the PLC addresses
of the physical process components. Prepare
process diagrams for the operators.

Driver Setup

Set up the appropriate communication drivers Setup program
to enable communication with the PLCs.

Event Report
Writer 1)

Set up custom reports to be viewed and
modified in MS Excel 2000.

Report program

IGSS32 Starter

Start and stop the configuration.

Main program

Job Scheduler

Schedule jobs for automatic execution at
regular intervals or based on events.

Utility

Maintenance 2)

Create maintenance jobs which define a
maintenance interval for specific process
components. When the interval is exceeded,
the operator gets a maintenance reminder.

Utility

Picture Install

Compress bitmaps for optimal resolution and
performance during supervision.

Utility

Report Formats

Define report formats to be used by the
operator during supervision.

Report program

Setup

Specify global settings for the system.

Setup program

Symbol Editor

Create or modify symbols. A default symbol
library is supplied. You can design your own
custom symbols in this program.

Utility

User
Administration

Define user names and passwords, user
groups and user privileges.

Setup program

WinPager 1)

Set up duty periods during which critical
alarms will be sent to the mobile phone or
personal pager of the duty personnel.
Combining this module with our WAP
interface allows you to control process
objects and manually add process data to
reports.

Utility

1)

Sold as a separate sales module.

7
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Extended version only.

Program name
Alarm

IGSS32 Starter
Maintenance

1)

Summary of use

Program type

Easily view alarms either directly on process
diagrams, in the Alarm List (active alarms) or
the Alarm Log (historical alarms). Handle
alarms based on recommended operator action
and document irregularities using operator
notes.

Main program

Start and stop the configuration.

Main program

Get maintenance reminders in the maintenance
or alarm list and perform the related
maintenance jobs.

Utility

Periodical
Reports

View or print a report for a given period (daily, Report program
weekly, monthly, quarterly or yearly).

Supervise

Monitor and control the plant. Alarm handling
is an integrated part of Supervise.

Main program

Manual Report
1)
Editor

Enter report values for process components
which are not directly included in the
configuration.

Report program

Alarm Statistics
Report

Get a statistical overview of historical alarms.

Report program

Snapshot Report

View or print a report with the current process
values.

Report program

1)

Extended version only.

8

9

Chapter 2 : IGSS Types and Templates

About this
chapter

This chapter contains the following information:
•= Definitions of the key IGSS object types
•= Examples of their typical use
•= Detailed descriptions of each IGSS object type
•= A description of IGSS templates

Contents

This chapter contains the following sections:
Section A: IGSS Types ....................................................................................................... 10
Section B: IGSS Templates................................................................................................. 49
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Section A: IGSS Types
Overview
About this section This section contains the following information:

•= Descriptions of each IGSS object type
•= Descriptions of the most important object properties
•= Descriptions of the dialogues used when defining new objects
•= A visual guide highlighting the most important properties
Contents

What Is an IGSS Type? ....................................................................................................... 11
The Area Object Type ......................................................................................................... 14
The Diagram Object Type ................................................................................................... 15
The Graph Object Type....................................................................................................... 20
The Analog Object Type ..................................................................................................... 24
The Table Object Type........................................................................................................ 31
The Counter Object Type .................................................................................................... 35
The Digital Object Type...................................................................................................... 38
The String Object Type ....................................................................................................... 40
The Scaling Object Type..................................................................................................... 43
Visual Guide to Object Types ............................................................................................. 45
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What Is an IGSS Type?
Definition

An IGSS type is a predefined system object that ensures that you provide all the necessary
information about each process component you define.
It reflects real life in the sense that different kinds of information is required for different
types of objects. For example, for a motor you need to be able to start and stop it and know
its maximum capacity. For a temperature gauge, you need to tell IGSS32 the temperature
range you want to accept and the unit of measurement.

Use

Each time you define a process component (an IGSS object), it must have the properties of
one of the IGSS types. When the relevant type is selected, you are automatically guided
through a definition sequence ensuring that you provide all the necessary information.

IGSS types

The following types are used in IGSS32:
•= Area
•= Diagram
•= Graph
•= Analog
•= Table
•= Counter
•= Digital
•= String
•= Scaling
Area, diagram and graph are non-process objects, that is, they do not represent a physical
process component, but they are containers of other objects. The remaining object types
represent process components, except scaling which is an internal object.
For a detailed description of each type, refer to the descriptions in this section.

Type versus
template

As you can see, an IGSS type is a generic system object. When building configurations you
will often see that many real life components are similar or share a number of properties:
one type of valve may be closed, half open and open, one type of level gauge may measure
levels between zero and 1000 m3. To automate the definition of such components, IGSS32
includes a facility to define your own templates when components are identical or share
several properties. A template holds all the information which is common to this set of
objects. Templates make it very fast to configure and to make several similar
configurations. For further information about templates, refer to Section B of this chapter.
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When you define a process component, you go through the following steps:
NOTE: This procedure applies to all object types except area, diagram and graph. For
specific information on a particular type, refer to the descriptions in this section. The tabs
described in the procedure are common to all object types. However, if you are using
special display types, for example, bar display, the Symbol Definition tab will be replaced
by a special tab for that display type.
Step
1

Action
Do the following:
·= Select Objects → <relevant menu item>. The Definition of Object dialogue
appears.
NOTE: This dialogue is the same no matter which type of object you are defining.

Figure 2.1 In the Definition of Object dialogue you select the relevant object type
and give the object you are about to define a unique name.

Section A: IGSS Types

2
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Select the relevant type and give the component a unique name. Press OK. The
type-specific dialogue appears (in this example for an analog object).

Figure 2.2 The first tab shows the name of the object type, for example, Analog.
The tab contains properties characteristic of precisely this type of component.

3

On the tab with the name of the object type (for example, Analog), enter
information characteristic of precisely this type of component.
EXAMPLE:If you are currently defining a temperature gauge, you would select the
measuring unit (ºC) and range of the temperature (-5 to 98) whereas you would
enter information about possible states and commands if you were defining a
motor.

4

On the Data Management Definitions tab, define the data management properties
for the component.
EXAMPLE: Specify how often IGSS32 is to fetch data from the PLC and whether
you want the data to be included in the operational reports.
NOTE: This tab is the same no matter what you are defining.

5

On the Display tab, define what you want to show along with the symbol (name,
description, etc.).

6

On the Edit Mapping tab, specify the PLC address(es) where the data for this
component is available or to which data must be written.
NOTE: This tab is the same no matter what you are defining.

14
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7

On the Symbol Definition tab, select the symbol you would like to use for the
process component and click OK. The object symbol and caption appear.
NOTE: This tab is the same no matter what you are defining (though the available
icons may, of course, differ).

8

Position the object symbol and caption on the diagram.

The Area Object Type
Definition

An area is a collection of diagrams, graphs and objects that belong together.

Use

Typically an area is used to depict a production line or a separate section of the process. If
the process cannot be seen as divided into sections, only one area is used.

Global area

IGSS32 includes a default area called Global. Everything that is defined in this area is
global to the entire configuration and may be used in any other area. Therefore, it is always
a good idea to define templates and scaling objects in this area. For a description of how
you define these objects, refer to “Define Scaling Objects and Templates” in Chapter 3.

User-defined
areas

When building your own configurations, you need to define your own areas. There are a
few things to remember when defining your own areas:
•= Give the area a unique and descriptive name so that it is easily recognised in the Area
menu.
•= All objects defined in a user-defined area are not available in other areas. If you know
that a particular object will only be used in one particular area, define it there to limit the
number of global objects.

Area menu

The Area menu contains all available areas provided that the Name to Menu option is
selected for each area (see below). These areas are selected by the operator in the Area
menu of Supervise.

Section A: IGSS Types
Defining an area
object

Step
1
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Action
Select Area → Create. The New Area Properties dialogue appears.

Figure 2.3 In the New Area Properties dialogue give the area a unique
name and select the Name to Menu option to show the name in the Area menu.

2

Type a unique name and select the Name to Menu option to show the area
name in the Area menu.

3

If required, enter a default node number and select a default PLC driver.
NOTE: The default node and driver are automatically suggested for all
objects you create in this area.

4

Optionally, attach a Protect object to protect the area against unauthorized
access.
NOTE: For further information about user administration, refer to the Help
function of User Administration.

For further details about areas, search for “areas” in the Definition Help file.

The Diagram Object Type
Definition

A diagram provides a graphical view of a section of the monitored process. A diagram
typically consists of a static background picture, a number of static process objects and
connectors and, most importantly, the dynamic process components represented as
symbols. A process diagram is often called a mimic diagram.

Use

A diagram defined in Definition is exactly the same diagram that the operator sees during
supervision. Depending on the complexity of the process, an area may contain a number of
diagrams each representing a section of the process. A diagram gives the operator a quick
overview of the monitored process and clear visual indication if there are any alarms.

16
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Diagram
background

In older versions of IGSS, the background picture of a diagram was made in an external
drawing application in either bitmap (*.bmp) or Windows metafile (*.wmf) format. This
option is still available, but many new graphics formats are supported, for example,
Enhanced Metafile (*.emf) and Graphics Interchange Format (*.gif).
You can also use a background color and build the diagram from scratch. You may still
need an external drawing application to create static components, such as tanks, containers,
etc. but these components can then be freely positioned and resized on the diagram. You
can easily draw the connectors between components using the Drawing toolbar.

Diagram menu

The Diagram menu shows all available diagrams in the current area provided that the Name
to Menu option is selected for each diagram. A checkmark beside the diagram name means
that the diagram is open. These diagrams are selected by the operator from the Diagram
menu of Supervise.

Section A: IGSS Types
Defining a
diagram

To define a diagram:
Step

The Definition of
New Diagram tab

17

Action

1

Select Diagram → Create.

2

Define how you want to display the diagram (see “The Definition of New
Diagram tab” below).

3

Assign function keys to the most commonly used operations (see “The
Function Key Assignment tab” below).

The figure below shows the Definition of New Diagram tab.

Figure 2.4 On this tab you specify the name of the diagram, include a background picture or
color and select various display options.

This tab contains the following important object properties:
Property

Description

Name

Enter a unique and descriptive name.

Name to Menu

Select this option if you want to show the diagram name in the
Diagram menu.

Background

Select Picture to include a background picture from an external
drawing application. Select Color to include a background color.

Miscellaneous
display options

Select the diagram window elements you want to show, for
example, Title Bar and Status Bar.

18
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For an explanation of the remaining items, click the
in the upper right hand corner of the
dialogue, then click the item you want information about.
The Function Key
Assignment tab

The figure below shows the Function Key Assignment tab.

Figure 2.5 On this tab you assign function keys to the most frequently used operations.

This tab contains the following important object properties:
Property
Function Keys

Description
Select the function key to which you want to assign an operation.
Note: By default, F1 is used to access Help, but you can
overwrite it, if required.

Object Name

Select the object that you want the function key to operate on.

Index

Select the atom you want the function key to activate, for
example, HA (High Alarm) for an analog object.

Command/Value

Select the command you want to execute or the value you want to
assign to the object when the key is pressed.

For an explanation of the remaining items, click the
in the upper right hand corner of the
dialogue, then click the item you want information about.

Section A: IGSS Types
The diagram
window
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The figure below shows an example of a diagram window:

Figure 2.6 The diagram window shows a section of the monitored process.

OLE-embedded
diagrams

You can also embed an OLE object as a diagram. This is useful, if you want the operator to
open an external application simply by choosing that diagram. When the OLE-embedded
diagram is opened, all the functionality of the server application is available.
For further information, search for “OLE-embedded diagrams” in the Definition Help file.
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The Graph Object Type
Definition

A graph is a graphical chart showing the value or state of one or more process components.
The data source for a graph can be either log files (*.log) or base class files (*.bcl). A
graph can show historical data, current data or a combination of both.

Use

Use a graph to achieve the following:
•= a graphical overview of the values and states of related process components
•= detect adverse trends at an early stage

Three types of
graphs

There are three types of graphs:
•= A predefined graph is a graph defined by the system designer which the operator can
access from the Graph menu or by clicking on a symbol representing the graph. Most of
the graph properties cannot be changed by the operator during supervision, but he can
change certain layout properties.
•= A dynamic graph is a graph created on-the-fly by the operator during supervision. The
operator simply selects the IGSS objects to include in the graph and then selects Graph
→ Create Dynamic Graph. This function is very useful, if the operator wants to monitor a
specific process component before and after an intervention. A dynamic graph can be
saved as a user-defined graph (*.usr). When re-opened, the graph will be dynamically
updated.
•= A static graph is a snapshot of a predefined or a dynamic graph that the operator wants
to save for documentation purposes. A static graph can be saved as a graph file (*.gph).
When re-opened, the graph can be shown, but not updated.

Export to CSV

The graph values can be exported to a comma-separated values (.csv) file. The values can
then be further processed in another program, for example, MS Excel.

Graph menu

The Graph menu shows all available graphs in the currently selected diagram provided that
the Name to Menu option is selected for each graph. A checkmark beside the graph name
means it is open.

Defining a graph
object

Step

Action

1

Select Graph → Create.

2

Define how you want to display the graph (see “The Definition of New Graph
dialogue” below).

Section A: IGSS Types

The Definition of
New Graph
dialogue

3

Define the graph properties (see “The Define Graph Parameters dialogue”
below).

4

Scale and position the resulting graph window.

21

In this dialogue you assign the name and description to the graph and define the window
elements you want on the graph window.

Figure 2.7 In this dialogue you assign the name and description to the graph and define the
window elements you want on the graph window.

This dialogue contains the following important object properties:
Property

Description

Name

Type a unique and descriptive name.

Name to Menu

Check this box to show the graph name in the Graph menu.

Miscellaneous
display options

Select the graph window elements you want to show, for example,
Title Bar and Status Bar.

22
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The Define Graph
Parameters
dialogue

The figure below shows the Define Graph Parameters dialogue.

Figure 2.8 In this dialogue you define which objects you want to represent in the graph, the
scaling of the axes, colors and various other properties.

The dialogue contains the following important object properties:
Property

Description

Start offset

Specify the offset from the current time with which you want the
graph to start.

Source

Choose either *.log files or *.bcl files as the data source for the
graph.

Object Name

Select the name of the object you want to show in the graph.

Atom
(log data only)

Select the name of the object atom you want to show, for
example, PV for the process value of an analog object.

Reduction
(BCL data only)

Select the relevant reduction method, for example, MV to show
the average value.

For an explanation of the remaining items, click the
in the upper right hand corner of the
dialogue, then click the item you want information about.

Section A: IGSS Types

The graph
window

The figure below shows an example of a graph window.

Figure 2.9 The graph window shows values or states of multiple process components.
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The Analog Object Type
Definition

An analog type in the IGSS system is used to represent a process component that can take
on any value within a specified range. Analog objects can include two sets of alarm limits
and a set point.

Use

The following examples show what analog objects may be used for:
•= a level gauge measuring the contents of a tank in litres. When the tank is empty, it
contains 0 litres and when full it holds 520 litres. This would mean that the analog IGSS
object would have a specified range of 0 to, for example, 550 litres.
•= a temperature gauge measuring room temperature within the limits -5 to 35 ºC (used in
the following example).

Defining an
analog object

To define an analog object:
NOTE: The following procedure describes how you define an analog object using standard
symbols. You may want to use alternative display types, for example, a bar display or a
circular display. For further information, search for “bar displays” or “circular displays”
in the Definition Help file.
Step

Action

1

Select Objects → Analog Objects. The Definition of Object dialogue appears.

2

Type a unique name and an optional description, then click OK. The analog
object properties dialogue appears.

3

Specify the measuring range, low and high alarm limits, number of decimals,
etc. (see “The Analog tab” below).

4

Specify how you want to collect and log your data (see “The Data
Management Definitions tab” below).

5

Specify what you want to show along with the symbol of the process
component (see “The Display tab” below).

6

Specify the PLC address of the process component and attach alarm texts (see
“The Edit Mapping tab” below).

7

Choose the symbol you want to represent the process component (see “The
Symbol Definition tab” below) and click OK. The object symbol and caption
appear.

8

Position the object symbol and caption on the diagram.
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The figure below shows the Analog tab:

Figure 2.10 On this tab you specify the measuring range, the desired process value, unit of
measurement, the number of decimals and alarm limits.

This tab contains the following important object properties:
Property
Alarm limits

Description
An analog object has two built-in sets of alarm limits expressing
varying degrees of serioussness that may be used if relevant - or
disabled if not required.
Alarm supervision is enabled simply by checking the box next to the
desired limit. When enabled, an alarm is generated and shown in the
Alarm List during supervision when the actual value exceeds or goes
below the limit.
TIP: You can easily enable or disable the individual limits on the
Edit Mapping tab.

Actual value

In this box you can type an initial process value. The value will, of
course, be updated dynamically during supervision; the value defined
in Definition is overwritten as soon as the data collection is started.

Set point

The set point is the desired process value, the value according to
which the process value is calibrated.
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For an explanation of the remaining items, click the
in the upper right hand corner of the
dialogue, then click the item you want information about.
Data Management The figure below shows the Data Management Definitions tab:
Definitions tab

Figure 2.11 On this tab you specify how you want to collect and log data.

This tab contains the following important object properties:
Property

Description
32

Scan interval

Decides how often IGSS scans the component address in the PLC
(the address itself is given on the Edit Mapping tab). In this example,
the temperature does not change very rapidly, so a scan interval of 30
seconds (30,000 msec) is selected. Note that if you are using eventoriented communication, you must select None.

Logging

With the logging buttons, you decide whether you would like the
system to save the values that are scanned with 30-second intervals for
this component in the log files. You only need to select logging for the
process components for which you want to log historical data (for
example, to be used in graphs). If you do not need logged data for a
particular component, select None. Note that the buttons have a
percentage next to them. If you click > 0 %, IGSS will save all changes
in log files. If you click > 10 %, the system will log all changes that are
larger than 10 %.
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Description

Base interval

Defines how often the system reduces the scanned values to one value
with the purpose of calculating statistics on the measured values. In
this example, a base interval of 10 minutes is used which means that
every 10 minutes, the system will reduce the up to 20 values (with a
scan interval of 30 seconds) to one value. This reduced, statistically
calculated value is subsequently used in the operational reports.

Data reduction

Defines how the data is reduced to one value according to the Scan
interval and Base interval settings. By clicking one or more boxes in
the Data reduction group, you select which method the system is to
reduce by: calculate an average, save the smallest or the largest value
in the 10-minute interval (Min and Max), calculate the sum of the
values in the 10-minute interval, save the latest value (Actual) or save
the number of times the process component has changed state
(Change). Which method you choose will depend on the nature of the
component. For a temperature measurement, Average is frequently
selected.

For an explanation of the remaining items, click the
in the upper right hand corner of the
dialogue, then click the item you want information about.
Display tab

The figure below shows the Display tab:

Figure 2.12 On this tab you specify what you want to show along with the symbol
of the process component.
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This tab contains the following important object properties:
Property

Description

Show

Check the relevant items you want to display on the diagram.

Symbol
selectable

Check this box to allow the operator to select the object symbol on
process diagrams.

For an explanation of the remaining items, click the
in the upper right hand corner of the
dialogue, then click the item you want information about.
Edit Mapping tab

On this tab you specify the PLC address of the process component and attach alarm text(s).
Note that a full PLC address consists of a node number, a data group, a word offset and a
bit offset. The figure below shows the Edit Mapping tab:

Figure 2.13 On this tab you specify the PLC address of the process component.

This tab contains the following important object properties:
Property
Configure atom

Description
Select the atom to which you want to assign a PLC address or an
alarm text. The number of atoms listed depends on your selections on
the Analog tab.
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Description

I/O mode

Select the relevant input/output mode in the drop-down list. In
addition to an actual value (Actual Value), this object has also been
configured with two sets of alarm limits and a set point; as this tab
reflects the decisions made on the Analog tab, six atoms are listed.
However, only one address needs to be entered, namely for the actual
value. This is due to the fact that the limits (high alarm, high limit,
low alarm and low limit) and the set point are all local to the PC
system. Other possibilities for the limits and the set point are: in, out
or in/out in which case PLC addresses should also be given for these
values. Normally, though, local is preferred.

Alarm Details

Either attach an existing alarm text by selecting it in the drop-down
list or create a new one by clicking New and then define the alarm
text properties in the ensuing dialogue.
An alarm number must be given for each alarm limit with alarm
supervision enabled on the Analog tab.
To edit an alarm text, select it in the drop-down list, click Edit and
change the alarm text properties, as required.
TIP: You can also create and edit alarm texts by selecting Edit →
Alarm Details.

Driver

Select the relevant PLC driver. The list of drivers corresponds to the
drivers included in the active driver profile. The drivers are
configured in Driver Setup.
TIP: You can select a default driver in the Area Properties dialogue.

Node

Enter the relevant node number to identify the PLC. Each PLC has a
unique number. When there is only one PLC, node number 0 is
default.
TIP: You can select a default node in the Area Properties dialogue.

Data Group

Enter the relevant data group. This setting identifies a section (data
group) of the memory layout of the PLC which consists of a number
of units or blocks of words (16 bit each).

Word Offset

Enter the relevant word offset. This setting identifies the precise
word within the data group. In this example, data for the temperature
measurement is read from PLC number 0, from data group number
20 and from word number 16 within that block.
NOTE: The system will always write one data word (that is, 16 bits)
at a time. The sending of a command means that the 16 bits are sent
to the PLC, even if only one or two bits have been defined as
command bits.
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Property

Description

Bit Offset

Enter the relevant bit offset. This setting identifies the precise bit
within the word of the data group.

External Type

The last bit of information the system needs is the external data type
in the PLC. Clicking the field will open a list of the data types
available for the selected PLC driver. In this example, FP16 (Fixed
Point 16 bit) is selected. Please refer to the relevant driver manual for
details. The external types are enabled or disabled in Driver Setup.

NOTE: Dependent on the PLC driver used, the text labels of the Data Group, Word Offset
and Bit Offset fields may be replaced by driver-specific terminology. However, if you want
to show the default terminology, hold down CTRL while you select the driver name.
For further details about driver configuration, refer to the Driver Setup Help file.
For further details about alarm texts, search for “alarm texts” in the Definition Help file.
Symbol Definition The figure below shows the Symbol Definition tab:
tab

Figure 2.14 On this tab you select the symbol you want to represent the process component.

This tab contains the following important object properties:
Property
Symbol color

Description
Select the color of the symbol.

Symbol angle Select an angle if you want to rotate the selected symbol.
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Select one of the symbol tables from the drop-down list. The table names
can be edited in Symbol Editor.
NOTE: IGSS32 automatically selects the relevant symbol table for the
object type you are currently defining.

Symbol
preview

Select the symbol you want to use. This field shows the symbols of the
currently selected symbol table.

For an explanation of the individual items in the dialogue, click the
in the upper right
hand corner of the dialogue, then click the item you want information about.

The Table Object Type
Definition

A table object, as is the case for an analog object, is used to represent a process component
that can take on any value within a specified range. However, a single table object may be
used for up to ten analog objects that belong together in some way.

Use

The following examples show what table objects may be used for:
•= temperature gauges placed at different levels in a tank. Being placed at different levels,
the gauges would probably give different measurements but it would still be interesting
to see their values presented together. Their values might be temperatures within a range
of say -3 to 40 ºC.
•= the oxygen uptake in a tank monitored at four different locations (used in the following
example).

When do I use a
table object?

You should use a table object:
•= when you have multiple analog objects that logically belong together and
•= share the same measuring range, alarm limits and alarm texts

Inheriting alarm
limits

A table object has no alarm limits and hence no alarm supervision. However, this may be
avoided by creating an analog object that defines the alarm limits for the table object. The
analog object is then connected to the table object by selecting the name of the analog
object in the Connect To drop-down list on the Data Management Definitions tab.
For further details about inheriting alarm limits, search for “table objects” in the Definition
Help file.
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Defining a table
object

To define a table object:
Step

Action

1

Select Objects → Tables. The Definition of Object dialogue appears.

2

Type a unique name and an optional description, then click OK. The table
object properties dialogue appears.

3

Specify the constituent analog objects, a minimum and a maximum value, the
number of decimals and measuring unit (see “The Table tab” below).

4

Specify how you want to collect and log your data (see “The Data
Management Definitions tab” below).

5

Specify what you want to display along with the symbol of the process
component (see “The Display tab” below).

6

Specify the PLC address of the table object (see “The Edit Mapping tab”
below).

7

Choose the symbol you want to represent the table object (see “The Symbol
Definition tab” below) and click OK. The object symbol and caption appear.

8

Position the object symbol and caption on the diagram.

Section A: IGSS Types

The Table tab

33

The figure below shows the Table tab:

Figure 2.15 On this tab you specify the constituent analog objects, a minimum and a
maximum value, the number of decimals and measuring unit.

This tab contains the following important object properties:
Property

Description

Name/Value

In this example, the oxygen uptake in a tank is monitored at four
different locations and the results are shown in a table as the values o1,
o2, o3 and o4.

Type

The values in the table are presented as fixed values with a fixed number
of decimals (Fixed Table).
You may choose to have the values in the table represented as floating
points instead (Float Table) in which case the values would be
represented as, for example, 7.00000e+000.

Decimal
Point

Type the desired number of decimals in the box.

Minimum
value

Enter a minimum value for the object.

Maximum
value

Enter a maximum value for the object.
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For an explanation of the remaining items, click the
in the upper right hand corner of the
dialogue, then click the item you want information about.
The Data
Management
Definitions tab

On this tab you specify how you want to collect and log data. This tab is identical to the
one for analog objects. In this example, we have chosen to scan every 30 seconds (the
oxygen uptake does not change suddenly) and to save all scanned values in the system's log
files. Statistics - in the form of an average value - is calculated every 10 minutes.
For further information about this tab, refer to the “The Analog Object Type” section.

The Display tab

On this tab you specify what you want show to along with the symbol of the process
component. The tab is identical to the one for analog objects.
For further information about this tab, refer to the “The Analog Object Type” section.

The Edit Mapping
tab

On this tab you specify the PLC address of the table object. Note that a full PLC address
consists of a node number, a data group, a word offset and a bit offset.
Note also that an external data type must be selected so that the system knows the PLC
format of the process value.
NOTE: Although a table object can handle up to ten process values, only one address is
given. This is because the system assumes that the values have consecutive PLC addresses.
For further information about this tab, refer to the “The Analog Object Type” section.

The Symbol
Definition tab

On this tab you select the symbol you want to represent the process component. This tab is
identical to the one for analog objects, except for the available symbols.
NOTE: IGSS32 automatically selects the relevant symbol table for the object type you are
currently defining, but you are free to choose one of the other symbol tables.
For further information about this tab, refer to the “The Analog Object Type” section.
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The Counter Object Type
Definition

A counter object is actually a variation on the standard analog type. Similar to the analog
type, a counter object may take on any value up to a given maximum. Unlike the analog
object type, though, a counter object has only one alarm limit. The operator can issue four
commands to a counter object: start, stop, reset and preset.

Use

A counter object is typically used for counting hours of operation of, for example, a motor
to ensure that maintenance is performed on time. This use would imply that the PLC
program would start the counter when the motor starts and stop it when the motor stops.

Defining a counter
object

Step
1

Action
Select Objects → Rectangular Field. The Definition of Object dialogue
appears.
NOTE: A counter object is frequently made as a click-sensitive area, that is,
an area on the screen merely displaying the name and the value.

When you define a rectangular field, you get a rectangle that you can freely
position and resize.
2

In the Type group, select Counter, type a unique name and an optional
description, then click OK. The counter object properties dialogue appears.

3

Type the alarm limit value and enable alarm supervision and type the preset
and maximum values (see “The Counter tab” below).

4

Specify how you want to collect and log your data (see “The Data
Management Definitions tab” below).

5

Specify what you want to show along with the symbol of the counter object
(see “The Display tab” below).

6

Specify the PLC address of the counter object and attach the alarm text (see
“The Edit Mapping tab” below).

7

Choose the symbol you want to represent the counter object (see “The
Symbol Definition tab” below) and click OK. The object symbol and caption
appear.

8

Position the counter object symbol and caption on the diagram.
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The Counter tab

The figure below shows the Counter tab:

Figure 2.16 On this tab you specify the preset and maximum values and whether you want
to enable alarm supervision.

This tab contains the following important object properties:
Property

Description

Limit

Check this box to enable alarm supervision so that an alarm will be
generated when the limit value is exceeded.

Preset value

Enter the value you want to insert when the operator issues the Preset
command.

Maximum
value

Enter the maximum value for this object.

NOTE: Seen from the point of view of the system designer, pressing any of the four option
buttons corresponds to sending a specific bit combination to the PLC. The bit combinations
for the four buttons are:
Start

1000

Stop

1001

Reset

1010

Preset

1011
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On this tab you specify how you want to collect and log data. This tab is identical to the
one for analog objects. In this example, we have chosen to scan every 30 seconds (the
motor does not start every other second) and we have chosen not to log (None) as we have
no wish to see the counter object's historical values. We do, however, want to see the object
values in the system's operational reports and therefore we have told the system to save the
process value every half hour (Base interval = 30 and Data reduction = Actual).
For further information about this tab, refer to the “The Analog Object Type” section.

The Display tab

On this tab you specify what you want to show along with the symbol of the counter object.
The tab is identical to the one for analog objects.
For further information about this tab, refer to the “The Analog Object Type” section.

The Edit Mapping
tab

On this tab you specify the PLC addresses of the counter object and attach the alarm text
for the alarm limit. Note that a full PLC address consists of a node number, a data group, a
word offset and a bit offset. The figure below shows the Edit Mapping tab.

Figure 2.17 On this tab you specify the PLC addresses of the counter object.

A counter object contains the following atoms:
Select this
atom …

and type the following:

Command

the address for the start/stop command that the operator can issue.

Count

the address where IGSS32 can read the current counter value.

Limit

In this example, we have chosen to use a local alarm limit, that is, an alarm
limit that exists only in IGSS32 and has no connection to the PLC.
You must also attach an alarm text for the counter alarm limit.
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Preset

the address to which the preset value is to be sent to when changed by the
operator.

Note also that an external data type must be selected so that the system knows the PLC
format of the process value. In this example, select Counter.
NOTE: For each individual atom (Command, Count, Limit and Preset), you can choose
I/O mode, that is, whether the system is to read from and/or write to an address in the PLC
(i/o, in, out) or whether the value is to be internal in the system only (local).
The Symbol
Definition tab

On this tab you select the symbol you want to represent the counter object. This tab is
identical to the one for analog objects, except for the available symbols.
NOTE: IGSS32 automatically selects the relevant symbol table for the object type you are
currently defining, but you are free to choose one of the other symbol tables.
For further information about this tab, refer to the “The Analog Object Type” section.

The Digital Object Type
Definition

A digital type is used to represent a process component that can take on a finite number of
states and commands. The operator can issue these commands to change the state of the
process component. Usually, digital objects are based on digital templates which offer
several advantages compared to standard digital objects.

Use

Typical uses of digital objects are as follows:
•= a valve that can be either open or closed
•= a motor that can be started, stopped and run at different speeds

The standard
digital type

In its most simple form, the IGSS digital type has two states: 0 and 1 and two commands
also called 0 and 1. The figure below shows the Change State tab of the object properties
dialogue of a standard digital object.

Section A: IGSS Types

39

Figure 2.18 The Change State tab of a standard digital object.

In the dialogue as you see it here, you have no possibilities of changing the state and
command names or the number of states and commands.
Other tabs

The remaining tabs in this dialogue are the same as for analog objects. For further
information, refer to “The Analog Object Type” in this section.

Define digital
templates

You will hardly ever define an object using the above type but you will practically always
use a digital template to define the digital object.
With a digital template you can
•= define exactly the number of states and commands you need
•= give states and commands the names you like
•= specify the valid commands for each state
•= define any number of alarms
•= obtain control right down to the individual bit
•= tailor a template to be used again and again
For a description of how you define a digital template, refer to “Defining an IGSS
Template” in Section B of this chapter.
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The String Object Type
Definition

A string object is a text field displaying a message related to the monitored process.

Use

Typically, a string object shows a message when a specific part of the PLC program is
running. In the following example, the operator will see a message on his screen when the
cleaning process is initiated.

Defining a string
object

To define a string object:
The following procedure assumes that you are using a rectangular field to display the string
object. Alternatively, you may want to show the string in an Edit box or a text box. For
further information, search for “standard descriptors” in the Definition Help file
Step

Action

1

Select Objects → Rectangular field. The Definition of Object dialogue
appears.

2

In the Type group, select String, type a unique name and an optional
description, then click OK. The string object properties dialogue appears.

3

Specify the text string you want to display and its max. length (see “The
String Object tab” below).

4

Specify how you want to collect and log your data (see “The Data
Management Definitions tab” below).

5

Specify what you want to display along with the text string (see “The Display
tab” below).

6

Specify the PLC address of the string object (see “The Edit Mapping tab”
below) and click OK. The rectangular field and object caption appear.

7

Position and resize the rectangular field representing the string object on the
diagram.
NOTE:An Attributes of Rectangle tab appears, if you double-click the field
allowing you to specify the precise co-ordinates, width and height of the field.
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The figure below shows the String Object tab:

Figure 2.19 On this tab you specify the text string to be displayed and its max. length.

This tab contains the following important object properties:
Property
Maximum length

Description
Enter the maximum number of characters you need for this text
string.
NOTE:You can use up to 70 characters.

String

The Data
Management
Definitions tab

Enter the text string you want to display.

On this tab you specify how you want to collect and log data. The tab is identical to the one
for analog objects.
You may select a scan interval and a log frequency. Note, though, that as it makes no sense
to perform any statistical calculations on a string, the Data reduction and Base interval
options are not selectable. Of course, the logged values cannot be presented in graphs as is
normally the case, but the log files may be displayed and printed.
For further information about this tab, refer to the “The Analog Object Type” section.
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The Display tab

On this tab you specify what you want to show along with the string object. The tab is
identical to the one for analog objects. For further information about this tab, refer to the
“The Analog Object Type” section.

The Edit Mapping
tab

On this tab you specify the PLC address of the string object. Note that a full PLC address
consists of a node number, a data group, a word offset and a bit offset. The figure below
shows the Edit Mapping tab.

Figure 2.20 On this tab you specify the PLC address of the string object.

A PLC address for a string object specifies the beginning of the string. The number of
characters defined in the Maximum length field on the String Object tab are automatically
reserved. Note also that you must select an external data type.
For further information about this tab, refer to the “The Analog Object Type” section.
For further details about string objects, search for “string objects” in the Definition Help
file.
The Attributes of
Rectangle tab

On this tab you can optionally specify the precise co-ordinates, width and height of the
rectangular field.
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The Scaling Object Type
Definition

A scaling object maps one set of values to another set of values. Note that a scaling object
is an internal object and therefore does not represent a physical process component.

Use

Use the scaling object when you need to map one set of values to another, instead of
writing the necessary PLC code. You can use a scaling object to convert values from one
measurement unit to another, for example, from °C (Celsius) to °F (Fahrenheit).
NOTE: You can also define unit conversions without using a scaling object. Search for
"Unit Conversion dialogue" in the Definition Help file.
To define such a scaling object, refer to “Define Scaling Objects” in Chapter 3.

Defining a scaling To define a scaling object:
object

NOTE: It is recommended to define scaling objects in the Global area to make them
globally available in the configuration.
Step

Action

1

Select Objects → New Unreferenced. The Definition of Object dialogue
appears.

2

In the Type group, select Scaling, type a unique name and an optional
description, then click OK. The scaling object properties dialogue appears.

3

Specify the input/output values (I/O value) and the corresponding values (Real
value) to which you want to map the original values (See “The Scaling
Specification tab” below).
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The Scaling
Specification tab

The figure below shows the Scaling Specification tab:

Figure 2.21 On this tab you specify the input/output values (I/O value) and the new values
(Real value) to which you want to map them.

This tab contains the following important object properties:
Property

Description

I/O value

Enter the input/output values you want to map to another set of values.

Real value

Enter the values you want to use instead of the input/output values.

In this example, the scaling object maps values within the area 4 to 20 onto values in the
area 0 to 100. This means that when, for instance, the value 12 is sent to IGSS32, the scaling
object maps the value onto 50.

Connecting a
scaling object to
an analog object

A scaling object may be used any number of times to scale analog values. To connect a
scaling object to an analog object:
Step

Action

1.

Open the diagram containing the analog object to which you want to connect
a scaling object.

2.

Double-click the symbol representing the analog object.

3.

Click the Data Management Definitions tab.

4.

In the Scale As field, select the appropriate scaling object in the drop-down
list which shows all scaling objects in the active configuration.
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Visual Guide to Type-specific Properties
Introduction

This section is a graphical illustration of the fields and buttons on the tabs containing the
type-specific properties.
When you are working with IGSS32, we highly recommend that you use the What’s This?
Help topics to get specific information on the individual item in a dialogue. For
information on how you use this function, refer to the “IGSS32 User Documentation”
section at the beginning of this manual.

Area

Enter a unique name of
max. 30 characters. Do
not use spaces in the
name.
Type the default node number
identifying the appropriate PLC in
the network. This node number is
automatically suggested for new
objects you create in this area.
Optionally, protect this area by
attaching a Protect object. If the
current user owns the user
privileges of the Protect object, he
gains access to this area.

Diagram

Enter an optional description of
max. 254 characters.
Check this box to show
the area name in the Area
menu.
Select a default driver in the dropdown list. The driver is
automatically suggested for new
objects you create in this area.

Enter a unique name of
max. 30 characters. Do
not use spaces in the
name.

Select Name or
Description to show either
in the title bar of the
diagram.

Enter an optional
description of max. 254
characters.

Displays a preview of the
selected background
picture or color.

Check the window elements
you want to show, for
example, the status bar.
Check this box before you
assign function keys on the
Function Key Assignment
tab.

Optionally, protect this diagram by
attaching a Protect object. If the
current user owns the user
privileges of the Protect object, he
gains access to this diagram.

Check this box to show the
diagram name in the
Diagram menu.
Select either Picture or
Color as the background
for you diagram. Click
Browse to find the
appropriate picture or color.
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Enter a unique name of
max. 30 characters. Do not
use spaces in the name.
Enter an optional
description of max. 254
characters.

Check the window elements
you want to show, for
example, the status bar.

Analog

Enter a unique name of
max. 30 characters. Do not
use spaces in the name.
Enter an optional
description of max. 254
characters.

Enter the max. value of the
analog object.
Enter the min. value of the
analog object.

Select Name or Description
to show either of the two in
the title bar of the graph.
Check this box to show the
graph name in the Graph
menu.
Check this box to display a
grid behind the graph.

Enter the desired number of
decimals.
Enter the desired unit.
Check this box to generate an
alarm when the actual value
exceeds the limit.
Enter the two high alarm limits.
Shows the process value
during supervision.
Enter the desired process
value.
Enter the two low alarm limits.

Move the horizontal lines to change the values for the
alarm limits, set point, etc. Use the color coding to
determine which line to move. The corresponding value
will change when you move the line.

Table

Enter a unique name of
max. 30 characters. Do not
use spaces in the name.

Enter an optional
description of max. 254
characters.
Enter the names of the
individual analog objects
(max. 10).
Enter the initial values of
the individual entries.

Check this box to generate an
alarm when the actual value
falls below the limit.

Select the type of table you
want.
Enter the desired number of
decimals.
Enter the desired
measuring unit.
Enter the min. value of the
object.
Enter the max. value of the
object.

Section A: IGSS Types
Counter

Enter a unique name of
max. 30 characters. Do not
use spaces in the name.
Enter an optional
description of max. 254
characters.
Check this box to generate
an alarm when the limit is
exceeded.
Enter the default value you
want to insert when the
operator selects Preset.
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Enter the desired
measuring unit.
Shows the four commands
available to the operator
during supervision.

Shows the actual value of
the counter object.

Enter the max. value of the
object.

Digital

Click the States and
Commands tab to specify
state and command names.
Shows the name of the
digital template.
Define the use of the
individual bits in the byte
sent from the PLC to the PC.
Define the use of the
individual bits in the byte
sent from the PC to the PLC.
Shows an explanation of the
characters used to define
how each bit is used.

Shows the optional
description.
Check the relevant boxes to define
whether the 32 bits are to be
interpreted individually or in
combination.
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Enter a unique name of
max. 30 characters. Do not
use spaces in the name.
Enter an optional description
of max. 254 characters.

Enter the max. length of
the text string.

Enter the text string you
want to show.

Scaling

Enter a unique name of
max. 30 characters. Do not
use spaces in the name.
Enter an optional
description of max. 254
characters.
Enter a range of incoming
values, for example, from 4
to 10. Max. 10 values may
be given.

Enter a range of real
values, for example, from 0
to 100 to which you want to
map the I/O values. Max.
10 values may be given.
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Section B: IGSS Templates
About this section This section contains the following information:

•= A description of what a template is and what it is used for
•= An example where we define a digital template
Contents

This chapter contains the following topics.
What Is an IGSS Template?................................................................................................ 49
Defining an IGSS Template ................................................................................................ 50

What Is an IGSS Template?
Definition

An IGSS template is a customised template - based on one of the IGSS object types - that
the user creates when a number of process components are very similar and share several
properties. The real process components are then defined using the template, thus
eliminating the repetitive task of entering the same information for each component. In fact,
the user only has to enter a unique name and a specific PLC address to make a new
component based on a template.

Why use
templates?

There are several reasons why you should use templates extensively:
•= They ensure consistency within a configuration for process components based on
common templates.
•= They save valuable engineering time by eliminating the need of entering the same
information for a number of very similar process components.
•= They limit the task of creating new process components to entering a unique name and a
specific PLC address.
•= They facilitate making changes to multiple objects at a time, simply by changing the
template properties.

Four types of
templates

Templates may be defined for the following object types:
•= Analog
•= Table
•= Counter
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•= Digital
The digital templates are the most widely used templates. The main difference between the
digital templates and the other template types is that you gain control right down to the
individual bit sent to and from IGSS32. For an example of how you define a digital
template, refer to “Defining an IGSS Template” in this section.
Built-in templates

A few templates are included for your convenience, for example, the PROTECT template
which is a template defining protection levels to be used in connection with the User
Administration program. If required, you may define new Protect objects based on the
PROTECT template.

Example: An
analog template

You have 16 different temperature gauges in your plant that all
•= measure temperatures in the range -5 to 35 ºC
•= share the same alarm limits
•= share the same alarm texts
•= have their current process value scanned every 10 seconds
•= must be included in the operational reports
This would mean that it would make perfect sense to make a template including all these
properties and then use this template to define each of the temperature gauges T1 to T16.
The only two properties that would be different in these 16 components would be their
name and their specific PLC addresses.

Defining an IGSS Template
This example

In the following example we will define a pump template, PUMP_3. The pump template
will have the following states and commands:
This command …

Advantages of
using a digital
template

Results in this state …

STOP

OFF

SLOW

SLOW

MEDIUM

MEDIUM

FAST

FAST

By defining a digital template you can:
•= define exactly the number of states and commands you need
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•= give states and commands the names you like
•= define any number of alarms
•= obtain control right down to the individual bit
•= tailor a template to be used again and again
Usually, you will define one template for each type of valve, motor, pump, etc. If you need
two templates for two different types of pumps, simply copy the first template (select
Template → Create Template) and use the Copy From function, make the necessary
adjustments and give it a new name, for example, PUMP_2.
Defining a digital
template

Step

Action

1.

Select Template → Create Template. The Create Template dialogue appears.

2.

In the Type group, select Digital and type a unique name for the template (in
this case, PUMP_3) and click OK. The digital template properties dialogue
appears.
NOTE: To easily distinguish the names of templates and process
components, we recommend that you use ALL CAPS for template names and
normal case for process components.

3.

Define the bits used for states and commands (see “The Bit Map I/O tab”
below).

4.

Define the bits used for alarm indication and alarm acknowledgement (see
“The Alarm In/Ack Bit tab” below).

5.

Assign names to the individual states and commands (see “The States and
Commands tab” below).

6.

Define the default command and valid commands for each state (see “The
Command/State Config tab” below).

7.

Specify how you want to collect and log your data (see “The Data
Management Definitions tab” below).

8.

Specify the parts of the PLC address which are common to all process
components you are going to base on this template (see “The Edit Mapping
tab” below).

9.

Choose a color and symbol for each state (see “The Symbol Definition tab”
below).

10.

Click OK to save the template.
RESULT:
The template is now ready for use. For an example where
we use a template to define a process component, refer to “Define Digital
templates” in Chapter 3.
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The Bit Map I/O
tab

The figure below shows the Bit Map I/O tab:

Figure 2.22 On this tab you specify how you want to use the individual bits sent to and from
IGSS32.

This tab contains the following important object properties:
Property
To PC
(State)

Description
Define how you want to use the individual bits communicated from the
PLC to IGSS32. You have 32 bits for state and command indicators.
In the example, bits 0 and 1 are used as state bits. The symbols are
described in the LEGEND.

From PC
(Command)

Define how you want to use the command bits sent from IGSS32 to the
PLC. Here two command bits are used. Similar to the two bits used for
states, two bits give you the opportunity to name four commands. The four
commands represent the four bit combinations: 00. 01, 10, 11.

For an explanation of the remaining items, click the
in the upper right hand corner of the
dialogue, then click the item you want information about.
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The figure below shows the Alarm In/Ack Bit tab:

Figure 2.23 On this tab you specify the alarm indication and alarm acknowledgement bits
sent to and from IGSS32.

This tab contains the following important object properties:
Property
To PC

Description
Define the alarm indication or alarm acknowledgement bits communicated
from the PLC to IGSS32.
In the example, bit 0 is used as an alarm indication bit (+) and 1 as an
alarm acknowledgement bit (*).

From PC

Define the alarm acknowledgement bit communicated from IGSS32 to the
PLC.
In the example, bit 0 is used as an alarm acknowledgement bit (*).

TIP: It is recommended to set an acknowledgement bit both To PC and From PC. This
ensures that the operator acknowledgement is sent to the PLC and that IGSS32 gets an
acknowledgement back from the PLC. If you only set it From PC, you cannot be sure that
the PLC has received the bit.
For details about alarm indication and acknowledgement bits, search for “alarms” in the
Definition Help file.
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The States and
Commands tab

The figure below shows the States and Commands tab:

Figure 2.24 On this tab you specify the names of the states and commands of the digital
template.

This tab contains the following important object properties:
NOTE: The number of states and commands is determined by the number of state and
command bits defined on the Bit Map I/O tab.
Property

The Data
Management
Definitions tab

Description

Add State

Renames the selected state in the list box with the state name you
enter or select. You can either enter a new state name or select
existing states by opening the drop-down list.

Add Command

Renames the selected command with the command name you enter or
select. You can either enter a new command name or select existing
commands by opening the drop-down list.

On this tab you specify how you want to collect and log data. This tab is identical to the
one for analog objects. In this example, we will choose Logging Out, because we want
every command that the operator issues to be registered in the system’s log files. We will
choose > 0 % because we want to log all state changes. Every five minutes the system saves
the number of state changes in the .bcl files (the data reduction method Change is selected).
These values are later used in the calculation of the values for the operational reports.
For further information about this tab, refer to the “The Analog Object Type” section.

The Edit Mapping
tab

On this tab you specify the PLC address of the process component. Note that a full PLC
address consists of a node number, a data group, a word offset and a bit offset.
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NOTE: Remember that we are defining a template and therefore we will not specify a
specific PLC address. What we can do, though, is to specify the node number and the data
group but leave the specific word and bit offset open to be defined for the individual
objects when they are subsequently defined.
Specifying alarm texts poses no problem - all components that will later share this template
will all share the same alarm texts.
For further information about this tab, refer to the “The Analog Object Type” section.
The Symbol
Definition tab

On this tab you select a color and a symbol for each state of the digital object. This tab is
identical to the one for analog objects, except for the available symbols.
By checking the Copy symbols to template box, you save all the color and symbol
selections as part of the template. When you later define new objects based on this
template, you can import these selections by clicking the Copy Symbols From Template
button.
For further information about this tab, refer to the “The Analog Object Type” section.

Advanced options There are a number of other possibilities in the dialogue that we will not describe in detail

here:
•= you may choose to look at the bit used for, for example, states as a single, individual bit,
or “un-coded” as some would have it, rather than as a bit combination. Looking at two
state bits individually would give three states rather than four, that is, one state for each
bit and the common zero state when all bits are set to 0.
•= you may choose to have the system automatically give alarm numbers consecutively
rather than select numbers yourself
•= you may choose to use inverse logic so that 0 rather than 1 means that a bit is set high
while 1 means that it is not set
For further details about advanced template options, search for “digital templates” in the
Definition Help file.
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Chapter 3 : How to Create a Configuration
Overview
About this
chapter

This chapter contains the following information:
•= A presentation of the sample configuration we are going to build
•= Step-by-step procedures for setting up and preconfiguring the configuration
•= Step-by-step procedures for building the configuration and installing it
•= Step-by-step procedures for refining the configuration with some of the more advanced
features in the system

About the
configuration

The sample configuration shows how you create objects of the different object types. The
procedures describe the most basic and typical ways of defining these objects.
If you are interested in more advanced ways of creating objects, refer to “Section D:
Refining the Configuration” in this chapter.

Contents

This chapter contains the following sections.
Section A: The Sample Configuration ................................................................................ 62
Section B: Setting Up and Preconfiguring .......................................................................... 65
Section C: Building the Configuration ................................................................................ 82
Section D: Refining the Configuration.............................................................................. 147
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Section A: The Sample Configuration
Overview
About this section This section contains the following information:

•= A detailed presentation of the configuration we are going to build
•= A configuration checklist which will help us ensure that all the necessary steps are
performed
Contents

This section contains the following topics.
The Configuration We Will Build ....................................................................................... 62
The Configuration Checklist................................................................................................ 63

The Configuration We Will Build
Introduction

In this chapter we will create a small IGSS configuration step by step. The configuration
consists of a tank into which water is filled and let out. The configuration we aim to create
looks like this:

Figure 3.1 The sample configuration we are going to build.
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In order not to introduce too much complexity, the sample configuration is run on a singleuser system. Once you are familiar with the basic configuration techniques, you can read
more about setting up multi-user systems in the "Multi-User Systems" book in the Setup
Help file.

The configuration The configuration consists of the following components (or objects in IGSS32 terminology):
components

Object name

IGSS type

Description

Overview

Diagram

The diagram showing the configuration. We will use the
built-in area called Global.

F0147

Analog

Measures the hourly flow of the water intake.

L0147

Analog

Displays the water level in the tank.

C0147

Counter

Counts the number of litres let into the tank per hour.

T0147

Table

Monitors the temperatures at different levels in the tank.

V1

Digital

Controls the water intake.

V2

Digital

Controls the water outlet.

Fahren.toCel

Scaling

Converts temperature values from Celsius (°C) to
Fahrenheit (°F).

Message

String

Describes the current state of the process. In this example,
the text “Now filling water into basin …” is shown.

The Configuration Checklist
Introduction

Before we start setting up and building the configuration, let’s take a look at the checklist
which is divided into two phases: “Setting up and preconfiguring” and “Building the
configuration”.

Setting up and
preconfiguring

We will go through the following procedures:
Procedure
Create the new configuration
Define the driver setup
Define IGSS station type

Mark when completed
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Set up global parameters
Set up data collection parameters
Set up alarm and log printers
Make background drawings
Plan alarm texts
Draw new symbols

Building the
configuration

We will go through the following procedures:
Procedure

Mark when completed

Define areas and diagrams (Overview)
Define scaling objects (Fahren.toCel) and
templates (Valve)
Define digital objects (V1 and V2)
Define analog objects (F0147 and L0147)
Define table objects (T0147)
Define counter objects (C0147)
Define string objects (Message)
Define alarm texts
Define graph windows (G0147)
Simulate process values
Install the configuration and troubleshoot
Define operator reports

Recommended
order

Note that the sequence of the configuration process given above is merely a recommended
order and is by no means compulsory. You can always go back to the previous procedure
and make any modification you like. Also, some of the procedures may or can be repeated
several times - this particularly goes for “Install the configuration and troubleshoot”, a
procedure that you will typically repeat after each step in the “Building the configuration”
phase.
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Section B: Setting Up and Preconfiguring
Overview
About this section This section takes you through the key properties in Setup and Driver Setup. For

information about the remaining functions and properties, refer to the Setup and Driver
Setup Help files.
About Setup

The Setup program is the program where you define the global settings for the IGSS
system.
NOTE: The Setup settings are not configuration-specific, so if you are working with
multiple configurations, make sure that you adjust the settings to the active configuration.

Contents

Create the New Configuration and Set It Active ................................................................. 65
Define the IGSS Station Type............................................................................................. 67
Set Up Global Parameters ................................................................................................... 68
Set Up Data Collection Parameters..................................................................................... 70
Set Up Alarm and Log Printers ........................................................................................... 71
Define the Driver Setup ...................................................................................................... 73
Make Background Drawings............................................................................................... 77
Plan Alarm Texts ................................................................................................................ 78
Draw New Symbols ............................................................................................................ 80
Checklist Review - Setting Up and Preconfiguring............................................................. 81

Create the New Configuration and Set It Active
Purpose

The very first thing you must do is to create a new configuration and give it a descriptive
name. We will name our sample configuration, Getting Started.
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To create a new
configuration

Step

Action

1.

In Definition, select File → New. The Name New Configuration dialogue
appears.

2.

Move to the folder where you want to place the configuration.
TIP:To create a new folder, click

3.

and type the name of the new folder.

In the File name box, type the name of the new configuration you want to
create (the extension *.elm is automatically added).
In this example, we call the configuration Getting Started.

Figure 3.2 In the Name New Configuration dialogue,
you type the name of the configuration.

4.

Click Save.
RESULT: The configuration is now created and loaded. A report folder,
Demo.R, is automatically created as a subfolder to the configuration root

folder.

Data folders

IGSS32 uses two key data folders:
•= one for the configuration data (Configuration root folder), for example, configuration file
(<MyConfig.elm), configuration database (<MyConfig >.mdb), etc.
•= one for the data files (Report folder), for example, base class files (*.bcl), log files
(*.log), alarm files (*.alm), etc.
For details about configuration folders and files, search for “configurations;folders and
files” in the Definition Help file.

Selecting the
active
configuration

If you are working with multiple configurations, you can always view and change the active
configuration in Setup. You can view the key data folders and files as follows.
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Action

1.

Select Start → Programs → IGSS32 3.0 → Setup. The Setup program
appears.

2.

Click the Folders tab.

Figure 3.3 On this tab you select the active configuration by selecting its key
folders and files.

Define the IGSS Station Type
Purpose

Before you start using your IGSS station, you must specify the station type (single-user,
operator or server) and assign a unique station name to it.

To define IGSS
station type

Perform the following steps:
Step
1.

Action
Click the Type tab.
Error! Not a valid link.
Figure 3.4 On this tab you select the Station type and assign a unique name to it.

2.

In the Station type group, select the appropriate station type. In this case, we
select Single.

3.

Type a unique name in the Station name box.
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Set Up the Global Parameters
Purpose

We will now review the global parameters to verify that they reflect our needs. The global
parameters include data management (Scan interval, Data reduction, etc.) and alarm
settings.

Global parameters Even though you may change these parameters, remember that -

•= the system has a default setting for each parameter so you do not have to make any
changes and
•= each parameter may be changed at any time later in the configuration process - BUT you
should, of course, be aware, that alterations will affect the entire configuration as well as
the data collection.
The following important global parameters can be modified on the Global Parameters tab:
Parameter
Max. number of
objects

Description
Type the max. number of objects allowed in your configuration.
NOTE: Although you initially bought a specific number of objects,
you may want to reduce the number to reflect your current need to
speed up the system performance. IGSS32 reserves memory for the
number of objects given here.

Alarm delay

Type the number of seconds an alarm must exist before being
registered as such. If you want to use the alarm delay, you enable it
on the Data Management Definitions tab when you define a process
component.

Full alarm count

Check this box to show the number of both acknowledged and
unacknowledged alarms. If disabled, only unacknowledged alarms
are counted.

Scan intervals

Type the four scan intervals that you want to be able to apply to the
IGSS objects in the configuration. The four scan intervals will be
shown on the Data Management Definitions tab and you will choose
one of them for each IGSS object.

Base intervals

Type the four base intervals that you want to be able to apply to the
IGSS objects in the configuration. The base interval determines how
often the scanned values are reduced to a data reduction value. The
data reduction method is selected in the Data reduction group.
The four base intervals will be shown on the Data Management
Definitions tab and you will choose one of them for each IGSS
object.
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Parameter

Description

Change logging

Type the four percentages with which you want to filter value
changes. Generally, IGSS32 logs values only when a value has
changed since the previous scan, but you may define that a change
must be greater than, for example, 5 % to be registered as a change
from the Data Management Definitions tab when you define a process
component.
Use this setting to prevent unnecessary logging of minor,
insignificant changes to the object values.

To set up global
parameters
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Perform the following steps:
Step
1.

Action
Click the Global Parameters tab.

Figure 3.5 On this tab you specify the key data management and alarm
settings.

2.

Modify the settings as required (see “Global parameters” above).

For further details about global parameters, search for “data management” and “alarm
settings” in the Setup Help file.
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Set Up the Data Collection Parameters
Purpose

When you start an IGSS configuration, the data collection engine (DC) is started. DC
handles many different tasks including updating of alarm, log and base class files, printing
of alarm and log data. On this tab, you determine how you want DC to operate.

Data collection
parameters

The following data collection parameters can be set:
Parameter

Description

Startup

Choose Manual or Auto startup of the data collection engine or
choose Supervise to automatically start both DC and Supervise.

Run update
frequency

Type the appropriate update frequency value, which determines
how often Supervise will refresh the process values on the process
diagrams in the configuration.

Start with
extended logging

Check this box if you want to log all values from the PLC driver.
This may be useful for troubleshooting purposes.
NOTE: The values are saved in the <MyConfig >.scn file in the
configuration root folder. By default, only alarm data packets are
written to the file.

Run simulated

To set up data
collection
parameters

Check this box if you want to use simulation data contained in the
<MyConfig>.sim file. See “Simulate Process Values” in this
section.

Perform the following steps:
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Action
Click the DC tab.

Figure 3.6 On this tab you specify the data collection parameters.

2.

Modify the settings as required (see “Data collection parameters” above).

Set Up the Alarm and Log Printers
Purpose

Before you can start printing alarm and log data from the system, you must set up the alarm
and log printers. Note that you do not define a graphics printer as in the older versions of
IGSS. When you print from Definition and Supervise, you simply select the Windows
printers defined on the IGSS station.

To set up alarm
and log printers

Perform the following steps:
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1.

Click the Printers tab.

Figure 3.7 On this tab you set up the alarm and log printers.

2.

In the Alarm group, select the printer type (Direct or Windows).

3.

Click the Printer button and select the printer you want to use for alarm
printouts.

4.

In the Log group, select the printer type (Direct or Windows).

5.

Click the Printer button and select the printer you want to use for log
printouts.

6.

In the Titles group, you can type the information you want to show on all
printouts from the system. This would typically be the plant name.

NOTE: If you are using the Direct option, only 1 line will be printed at a time. If you are
using the Windows option, you will be using the Windows printer driver which will print
one page at a time.
TIP: Use the Page Setup button to specify paper size, paper orientation, margins, etc.
The remaining
tabs in Setup

For our sample configuration, we will keep the default settings for the remaining tabs in
Setup.
For further details about these tabs, refer to the Setup Help file.
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Define the Driver Setup
Purpose

Before we start defining the process components in Definition, we must set up the PLC
driver(s) we want to use.

This example

For our small configuration, we use the Siemens serial 3964R/RK512 interface driver which
is directly connected to the COM1 port of the IGSS single-user station. We define one node
(PLC) to which all the process components are connected.

To define the
driver setup

Step
1.

Action
Select Start → Programs → IGSS32 3.0 → Driver Setup.
At this point, there is no driver profile associated with the configuration we
just created in Definition and set active in Setup. Therefore this message
appears.

2.

Click OK. The Save Profile As dialogue appears.
Type the name of the driver profile. This will typically be the same name as
you gave the configuration. In this case, we call it Getting Started. By default,
the new driver profile is set active.

Figure 3.8 Give the driver profile a descriptive name. This will typically be the same
name as you gave the configuration.
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3.

4.

5.

Click OK. The main window of Driver Setup appears. Make sure that the title
bar shows the path and name of the Getting Started configuration and the
name of the driver profile, Getting Started.

Select Edit → New Station or click
to add the single-user station we will
be using for configuring and monitoring the configuration. A default station
name appears in the tree view.
On the Station Configuration tab, do the following:
•= In the IGSS station name field, type the station name we assigned to the
station in Setup, IgssStation1.
NOTE: Station names are case-sensitive.
•= Leave the remaining settings as is, making sure that Station type is set to
Server or single user because we run a single-user system.
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6.

Select Edit → New Driver or click
3964R/RK512 interface driver.
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and double-click the Siemens serial

Figure 3.9 Double-click the driver you want to include in the driver profile.

7.

Select Edit → New Interface or click
added in the tree view.

. A COM1 interface is automatically

NOTE: To use another COM port or set the communication parameters, you
can click the Serial Port tab and change the options, as required.
8.

Click the + sign beside COM1 and notice that IGSS32 has automatically added
the first node (PLC). Select the node icon to view the node properties. As you
can see, node number 0 is suggested and we will keep this setting.

Figure 3.10 The tree view shows all the components of the driver profile. You can
expand or collapse the view using the + and - signs.
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9.

Select File → Save Profile or click
. The driver settings are now written to
the configuration's database, <MyConfig>.mdb.
The driver profile is ready for use and will be activated when you start the
configuration.
NOTE: In a multi-user system, you must install the configuration in order to
distribute the driver settings to the remaining IGSS stations on the network.

Figure 3.11 The driver profile is now complete and ready for use.

Subnodes

If you need to communicate with PLCs that do not have a direct connection to an IGSS
server or operator station, you can communicate with those PLCs (called subnodes in
IGSS) through a manager node (gateway PLC). This may be the case if you have two
separate networks in a plant, a LAN network and a dedicated PLC network. The gateway
PLC would then be accessible through the LAN network and would handle all
communication to the subnode(s) on the PLC network.
For further details on subnodes, search for "subnodes" in the Driver Setup Help file.

Special types of
telegrams

In Driver Setup, you can exchange different kinds of telegrams between IGSS and the
PLCs (nodes). These telegrams include system events, time synchronisation and keep alive
telegrams. They are defined on the Advanced tab at the node level.
For further details, search for "telegrams; using extended services" in the Driver Setup
Help file.
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Make the Background Drawings
Purpose

A background drawing for the configuration holds all that is static in the process. The
dynamic process components are subsequently defined in Definition.
NOTE: You can also use a background color for your diagrams and build the process
picture from scratch.

Formats
supported

In order to use a background drawing in IGSS32, it must be saved in one of the supported
formats. To view the list of supported formats, open the Diagram Properties dialogue,
select the Picture option, click Browse and open the Files of type drop-down list. The
supported file formats include the well-known formats used on the Internet (*.jpg and
*.gif).
TIP: You can also use native drawing program formats, for example, CorelDraw (*.cdr),
Adobe Photoshop (*.psd), etc.

To create a
background
drawing

Perform the following steps:
Step
1.

Action
Open the drawing program you have chosen to use, for example, CorelDraw.
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2.

Draw the background picture. Include all parts that are static in the process.
TIP: You do not need to include static text on the picture. This can be done
directly in Definition where the text can be freely formatted.

Figure 3.12 The background picture is made in an external drawing
application.

3.

Save or convert the picture to one of the supported formats.
NOTE: The background picture is later chosen as part of the diagram
definition procedure.

Plan the Alarm Texts
Purpose

We recommend that you plan and structure alarm texts, priorities and alarm colors at an
early stage in the configuration process to obtain consistency. Planning decisions include
determining the number of alarm priorities to be used, associating a color with each alarm
priority, planning reuse of alarm texts (the same alarm text can be associated with as many
objects as you like).

What is an alarm
text?

An alarm text is a general description of an error situation, for example, “Motor
overheated”. Each alarm text consists of the following properties:
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Description

Alarm No.

Identifies the alarm text with a unique alarm number. If you are
creating a new alarm text, the next available number is automatically
suggested, but you can change it, if required.

Priority

Type a priority from 255 (highest priority) to 1 (lowest priority).
TIP: Carefully plan alarm priorities and their associated colors. To
help the operator immediately understand the alarm priority, be
consistent and use only a limited number of alarm priorities.

Alarm and
acknowledge
colors

Specify the colors for alarm and acknowledged states and enable or
disable blinking of object symbols on process diagrams.
TIP: To help the operator easily distinguish between an object in
alarm and an object where the alarm is acknowledged, check Blinking
for the alarm color and uncheck it for the acknowledge color.

Alarm Text

Write a brief description of the alarm situation. This is the text that
the operator will see in the Alarm List when the alarm occurs.

Sound

Specify whether you want to play a sound when this alarm occurs.
The sound can be either a beep or a sound file (*.wav).

Event on alarm

Specify the event(s) you want to trigger when this alarm occurs. The
following events are available:
·= To WinPager sends the alarm number via WinPager to a mobile
phone or personal pager. Use this function to ensure that alarms
are handled during periods where the operator stations are
unmanned.
·= To PLC sends an alarm change telegram to the selected PLC,
provided that it is enabled in Driver Setup.
·= To Print prints the alarm text on the alarm printer.
·= Auto Ack automatically acknowledges the alarm when it occurs.
Use this setting for intermittent alarms.

Instructions

Gives recommended operator action should this alarm situation arise.
The operator can access the instructions from the process diagram
and from the alarm list.

Copy

Select an existing alarm text in the drop-down list, then click Copy to
copy its properties to the current alarm text. The properties can then
be freely changed.
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Draw the New Symbols
Purpose

IGSS32 comes with a large library of symbols (about 150). If these symbols are sufficient
for your needs, you can skip this procedure. However, you can easily modify the existing
symbols or draw new symbols.

Symbol tables

The above-mentioned library of symbols is contained in the symbol file, Symbols.v12. The
file consists of a number of subtables, each containing symbols for a specific type of
component, for example, valves. The names of the subtables of Symbols.v12 are the ones
you see in lower part of the Objects menu and on the Symbol Definition tab when you
define process components. You can change the names of the subtables in Symbol Editor.

To draw new
symbols

Perform the following steps:
Step

Action

1.

Select Start → Programs → IGSS32 3.0 → Symbol Editor.

2.

Open the Symbols.v12 file located in the <Installation path>\Gssdemo\Eng
folder.

3.

In the SubTable List, click the subtable to which you want to append a new
symbol.

4.

Use the scroll bar to find an empty symbol position marked No Name and
select it.

5.

Draw the new symbol.

Section B: Setting Up and Preconfiguring

6.

Click
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to save the Symbols.v12 file.

RESULT: You can now select the new symbol, when you define a new
process component in Definition.

Checklist Review - Setting Up and Preconfiguring
Review

The Setting Up and Preconfiguring phase is now completed. To sum up, we have now done
the following:
Procedure

Mark when completed

Specified configuration folders and files

√

Defined IGSS station type

√

Set up global parameters

√

Set up data collection parameters

√

Set up alarm and log printers

√

Defined the driver setup

√

Made background drawings

√

Planned alarm texts

√

Drawn new symbols

√
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Section C: Building the Configuration
Overview
About this section This section contains the following information:

•= A short introduction to Definition
•= Step-by-step procedures for creating the sample configuration
Contents

This section contains the following topics.
Checklist Review - Building the Configuration................................................................... 83
The Definition Program....................................................................................................... 83
Define Measurement Units .................................................................................................. 86
Define Areas and Diagrams................................................................................................. 88
Define Scaling Objects ........................................................................................................ 90
Define Digital Templates..................................................................................................... 92
Define Digital Objects......................................................................................................... 98
Define Analog Objects ...................................................................................................... 103
Define Table Objects......................................................................................................... 112
Define Counter Objects ..................................................................................................... 117
Define String Objects ........................................................................................................ 122
Define Alarm Texts ........................................................................................................... 127
Define Graph Windows ..................................................................................................... 130
Install the Configuration.................................................................................................... 134
Simulate Process Values.................................................................................................... 139
Define Operator Reports ................................................................................................... 141
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Checklist Review - Building the Configuration
What we need to
do

Let us take a look at the checklist again and see what we need to do to complete the
configuration:
Procedure

Mark when completed

Define areas and diagrams (Overview)
Define scaling objects (Fahren.toCel) and
templates (VALVE)
Define digital objects (V1 and V2)
Define analog objects (F0147 and L0147)
Define table objects (T0147)
Define counter objects (C0147)
Define string objects (Message)
Define alarm texts
Define graph windows (G0147)
Simulate process values
Install the configuration and troubleshoot
Define operator reports

The Definition Program
Introduction

Most of the remaining procedures in this section are performed in Definition. This topic
tells you how to access Definition and gives a brief introduction to the menus.

To start

Click Start → Programs → IGSS32 3.0 → Definition.
TIP: The fastest way to open Definition is to create a shortcut icon on the Windows
desktop. To learn how to do this, look up “Shortcuts; adding to the desktop” in Windows
Help.
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The table below summarises the pull-down menus in Definition:
This menu …
File

allows you to …
create, open, save and install configurations, revert to the previous
version, print diagrams or screen pictures and close the program.
NOTE: It is recommended that you save your work regularly using the
Save command (the keyboard shortcut is CTRL + S).

Edit

cut, copy, paste and delete objects or just their references on a diagram,
select and find objects, and view and modify the properties of areas,
diagrams, graphs and process components.
TIP: You can also view the properties of an IGSS object by rightclicking the object and selecting Properties in the popup menu.

View

show or hide the toolbars and the status bar, change the date/time
display, and show all states of digital objects.

Format

format text, set colors, set grid size and enable snap to grid, set initial
display for each area, align objects and stack objects on the diagram.

Area

create and delete areas and select any of the existing areas in the
current configuration provided that the Name to Menu option is
selected for each area.

Diagram

create and delete diagrams and select any of the existing diagrams
within the current area provided that the Name to Menu option is
selected for each diagram.

Graph

create and delete graphs and select any of the existing graphs within
the current area provided that the Name to Menu option is selected for
each graph.

Template

edit, copy and delete all object templates in the current configuration.

Objects

define any type of object either using the standard display types (upper
part of the menu) or using the symbols from the symbol file (lower part
of the menu).
NOTE: This menu is only available when a diagram is open.

User Programs

add links to external programs that the operator can use during
supervision.

Tools

configure the menus and toolbars of Definition and Supervise, delete
all objects or delete all objects except templates.

Window

close the current window and select any of the currently open diagram
or graph windows.

Section C: Building the Configuration

This menu …
Help
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allows you to …
open the Definition Help file and view the version number.

For details about the individual menu items, search for “menus” in the Definition Help file.
Right-click menus Apart from the pull-down menus, a number of right-click menus (or context menus) are

available.
For further details, search for “right-click menus” in the Definition Help file.
Toolbars

To provide easy access to the most frequently used commands, a number of toolbars are
available. Some of them are predefined, others can be customized by you.
For further details, search for “toolbars” in the Definition Help file.
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Define Measurement Units
Purpose

Some of the process components have a measurement unit. We will now define all the units
we need for the configuration and these units are then selected as part of the object
definition procedure.

Units in IGSS

To ensure consistency in the use of measurement units, IGSS features a number of unitrelated functions. You start by creating a units set into which the individual base units are
put.
By default, a units set called SI is included. You can define your own units sets, if required.
If you convert a configuration from an older version, the units are imported into the SI units
set
For further details about units sets and unit conversion, search for "units" in the Definition
Help file.

Units in the
configuration

To define
measurement
units

For the sample configuration we need the following measurement units:
Object name

Unit

F0147

l/h

L0147

l

C0147

l/h

T0147

°C

We need three different measurement units which are defined as follows:
Step
1.

Action
Select Edit → Base Units. The Base Units dialogue appears.

Section C: Building the Configuration

Step
2.
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Action
Click New to add a new base unit.
•=

In the Unit text field, type l for litre.

•=

Click OK to save and return to the Base Units dialogue.

Figure 3.13 In this dialogue you define new base units. If you have several
units sets, you select the relevant one in the drop-down list.

2.

Repeat step 2 for the l/h and °C base units.

Figure 3.14 The three base units are now created and can be chosen when
we later create the process components.

3.

Click Close.
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Define Areas and Diagrams
Purpose

Before we start defining the process components, we need an area and the process diagram
on which we want to show the process.
For details about areas and diagrams, refer to “The Area Object Type” and “The Diagram
Object Type” in Chapter 2.

To define the area For our small process we only need one area. We will use the built-in area called Global.
(Global)
To define the
diagram
(Overview)

We will define the diagram for our process which we will call Overview. Perform the
following steps:
Step
1.

Action
Select Diagram → Create. The Diagram Properties dialogue appears.

Figure 3.15 In this dialogue you define the properties of the Overview
diagram.

2.

In the Name field, type Overview and leave the Description field blank.

3.

Check the Name to Menu option to allow operators to open it from the
Diagram menu during supervision.

Section C: Building the Configuration

Step
4.
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Action
Leave the Keep Window option unchecked.
NOTE: During supervision five diagrams may be open simultaneously.
When diagram number six is opened, the system automatically closes the first
one. However, if you check the Keep Window option, the diagram is never
closed automatically. In this case we only have one diagram, so there is no
need to use the option.

5.

Define which window elements you want to show on the diagram, for
example, Status Bar (the information line at the bottom of the diagram).

6.

In the Background group, select Picture and click Browse to find the picture
which is located in the <Installation path>\Samples folder. The Open a
Background Picture dialogue appears.

Figure 3.16 In this dialogue you choose the background picture for the
diagram.

90

IGSS

32

Getting Started

Step
7.

Action
Double-click the file Waterx.wmf.
RESULT:

The new Overview diagram appears.

Figure 3.17 The Overview diagram is ready.

Define Scaling Objects
Purpose

We are going to monitor the temperature in the basin. However, the actual meter we are
using can only use the Fahrenheit scale and our operator is more used to the Celsius scale.
This, of course, we could work around in our PLC programming but by using a scaling
object we can save quite a few lines of PLC code. In our small configuration the scaling
object is only to be used once. The general idea, though, is that you may reuse a scaling
object as many times as you need.
NOTE: This example uses the scaling object to perform a unit conversion. This can also
be done using the Unit Conversion function in the Edit menu.

Section C: Building the Configuration

To define the
scaling object
(Fahren.toCel)

Perform the following steps:
Step
1.

Action
Select Objects → New Unreferenced. The Definition of Object dialogue
appears. Select Scaling and enter the name Fahren.toCel in the Name
field.

Figure 3.18 In this dialogue you select the object type and give the object a
unique name.

2.

Click OK. The scaling object properties dialogue appears. On the Scaling
Specification tab, enter the Fahrenheit values in the I/O value column and the
corresponding Celsius values in the Real value column as shown in Figure
3.19.

Figure 3.19 On this tab you enter the Fahrenheit values (I/O value) and the
corresponding Celsius values (Real value). The scaling can be linear or non-linear.
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Step
4.

Action
Click OK.
RESULT:
The scaling object is now complete. You can, of course,
reuse the scaling object as many times as you like.

Define Digital Templates
Purpose

In the configuration we have two valves. Instead of defining them one by one we will
define a valve template to ensure that both valves share the same properties.

To define the
digital template
(VALVE)

Perform the following steps:
Step
1.

Action
Select Template → Create. The Create Template dialogue appears.
Select Digital and type VALVE in the Name field and 2-state valve in
the Description field.

Figure 3.20 In this dialogue you select the template type and type a unique
template name and an optional description.

Section C: Building the Configuration

Step
2.
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Action
Click OK. The digital template properties dialogue appears.
On the Bit Map I/O tab, define a state bit in the To PC field and a command bit
in the From PC field. See the LEGEND for an explanation of the symbols
used.

Figure 3.21 On the Bit Map I/O tab you define the individual bits sent to and
from IGSS32.

3.

Click the Alarm In/Ack bit tab and define an alarm indication bit To PC (bit 0)
and alarm acknowledgement bits (bit 1 to PC and bit 0 from PC) .

Figure 3.22 On this tab you define the alarm indication and
acknowledgement bits.
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Step
4.

Action
Click on the States and Commands tab. Do the following:
·= Type the state names closed and open and click Add State after each.
·= Type the command names close and open and click Add Command
after each.

Figure 3.23 On the States and Commands tab you define the names of the
individual states and commands.

Section C: Building the Configuration

Step
5.
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Action
Click the Command/State Config tab and do the following:
·= In the States list, select Closed
·= In the Commands list, clear the close check box.

·= In the Default Command drop-down list, select open.
Repeat for the open state, but choose close as the default command.

Figure 3.24 On this tab you specify the valid and default commands for each
state.

6.

Click the Data Management Definitions tab and set the Scan interval, Data
reduction and Base interval to the settings shown in Figure 3.25.

Figure 3.25 On the Data Management Definitions tab you define the data
collection properties.
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Step
7.

Action
Click the Edit Mapping tab.
NOTE: The more information you can type into a template, the less work
you will have when using the template to define objects. So we can type all
address information which will be common to the valves.

Figure 3.26 On the Edit Mapping tab you define the parts of the PLC
address which are common to the objects you will base on this template.

Section C: Building the Configuration

Step
8.

Action
Type the following information:
•= Select Command or State in the Configure atom box.
•= In the I/O mode field, select out for command and in for state.
•= Select Alarm-In and in the Alarm Details field, select alarm number 101 as
described in “Define Alarm Texts” in Chapter 3.
•= In the Driver field, select the appropriate driver, 7T3964R (IgssStation1).
•= In the Node field, type 0 (the node number we defined in Driver Setup).
•= In the Data Group field, type 22 for command and 23 for state.
NOTE:To make the communication as efficient as possible, we will use one
block for commands and another one for states. That way the driver will not
scan any unnecessary data (i.e. commands) that will merely be discarded
when collecting changes of state.
·= Leave the Word offset field unchanged.
·= Leave the Bit Offset field open, as each object will have its own specific
address.
·= In the External Type drop-down list, select the FP16 data type.

97

98

IGSS

32

Getting Started

Step
9.

Action
Click the Symbol Definition tab. Do the following:
•= Check the Copy symbols to template box to save the colour and symbol
selections that you are about to make as a part of the template.
•= In the Digital state for symbol field, select Closed.
•= In the Symbol color drop-down list, select a yellow colour to represent the
state.
•= In the Choose symbol group, select the symbol that you want to represent
the state.

Figure 3.27 On the Symbol Definition tab, you select the colours and the
symbols for the various states.

10.

Repeat step 9 for the Open state, but select a green colour instead.

11.

Click OK, and the digital template is complete.

Define Digital Objects
Purpose

At this point we have a diagram without any objects, a scaling object and a digital template
- in other words we have all the basic building blocks for our configuration.
We will begin by defining the two valves, V1 and V2, that use the digital template,
VALVE.

Section C: Building the Configuration
To define the two TIP: The only properties we need to define for the two valves are their specific PLC
valves (V1 and V2) addresses and their symbols.

Perform the following steps:
Step
1.

Action
Select Objects → Valves. The Definition of Object dialogue appears.
Select VALVE in the Template drop-down list and type V1 in the Name field.

Figure 3.28 In this dialogue, you select the appropriate template and type
the unique name of the new object.
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Step
2.

Action
On the Edit Mapping tab, type the precise PLC addresses. We will use the
same offset for state and command - this will help us create consistency in the
PLC programming.

Figure 3.29 On the Edit Mapping tab you type the precise PLC address and
the alarm numbers.

Section C: Building the Configuration

Step
3.
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Action
Click on the Symbol Definition tab. Do the following:
·= Click the Copy Symbols from Template button to use the colour and
symbol selections you defined as part of the template.
TIP: If you want to turn the symbol by, for example, 90° to represent the
state open, simply select that percentage in the Symbol Angle drop-down list.

Figure 3.30 On the Symbol Definition tab, you select colours and symbols
or you use the selections from the template.

4.

Click OK. The two state symbols appear on the diagram. By default, they are
placed on top of each other, but you may move them individually, if required
(select View → Show All States).
Position the symbol, then the name and the state.

5.

Repeat steps 1 - 4 for V2, but use a Word offset of 17 for both state and
command.
NOTE: As both V1 and V2 use only one state bit, we could have used 16.1
as the bit offset for state. However, in our example it is not necessary to pack
the states (it is only a very small configuration). Also, it is pleasantly
symmetrical to use the same bit offset for state and command.
Note that command bits cannot be packed. The system always writes (at least)
one word (16 bits) at a time.
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Step

Action

6.

Click on the Symbol Definition tab and click Copy Symbols from Template to
select the same colors and symbols as for V1.

8.

Position the symbol, name and state for V2.

Figure 3.31 The Overview diagram with the two valves in position.
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Define Analog Objects
Purpose

In our configuration we need two analog objects:
•= the flow meter measuring the flow into the tank, F0147
•= the water level in the tank, L0147

To define the flow Perform the following steps:
meter (F0147)

Step
1.

Action
Select Objects → Analog Objects. The Definition of Object dialogue appears.
In the Name field, type F0147 and in the Description field, type Flow
into tank T0147.

Figure 3.31 In the Definition of Object dialogue you type the unique name
of the object and an optional description.
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Step
2.

Action
Click OK. The analog object properties dialogue appears. Do the following:
·= Adjust all the values as shown in Figure 3.32 using the keyboard or by
moving the appropriate horizontal line in the bar to the desired value. The
flow meter measures in the range 0 - 100 litres an hour (l/h).
·= In the Units box, select the measuring unit l/h.
·= Check the four limit and alarm boxes, High Alarm, High Limit, Low Limit
and Low Alarm.
NOTE: The Actual Value is, of course, updated as soon as the data collection
starts.

Figure 3.32 On the Analog tab you specify the measuring range, the
measuring unit and the alarm limits.
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Step
3.
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Action
Click the Data Management Definitions tab and make the selections shown in
Figure 3.33.

Figure 3.33 On the Data Management Definitions tab you define the data
collection properties.
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Step
4.

Action
Click the Edit Mapping tab and do the following:
•= In the Configure atom box, select Actual Value.
•= In the Data Group field, type 20. We choose a different data group for our
analog measurements than for the digital ones.
NOTE: The other five values are local to the PC and thus have no PLC
address.
•= In the Configure atom box, select High Alarm and select the associated
alarm text (number 102) as described in “Define Alarm Texts” in Chapter
3.
•= Repeat for High Limit (alarm no. 103), Low Limit (alarm no. 104) and Low
Alarm (alarm no. 105).

Figure 3.34 On the Edit Mapping tab you type the specific PLC address and
attach the appropriate alarm texts.

5.

Click the Symbol Definition tab and select a color and a symbol.

6.

Click OK. The symbol appears on the diagram. Position the symbol, then the
name and the value. See Figure 3.40.

Section C: Building the Configuration
To define a bar
display of the
water level
(L0147)
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Perform the following steps:
Step
1.

Action
Select Objects → Bar Display. The Definition of Object dialogue appears.
Select Analog and type L0147 in the Name field, then type Water level
in tank T0147 in the Description field.

Figure 3.35 In the Definition of Object dialogue you type the unique name of
the object and an optional description.
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Step
2.

Action
Click OK. The bar display object properties dialogue appears. Do the
following:
•= Adjust the maximum value to 1000.
•= Remove all values except High Alarm, Actual Value and Low Alarm by
moving the corresponding horizontal line above the top or below the
bottom of the bar. Use the color-coding to determine which line to move.
A quicker alternative is to clear the check boxes for the atoms you do not
want to use on the Edit Mapping tab.
•= In the Units drop-down list, select l for litre.

Figure 3.36 On the Analog tab you specify the measuring range, the
measuring unit and the alarm limits.
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Step
3.

109

Action
Click the Data Management Definitions tab and make the selections shown in
Figure 3.37.

Figure 3.37 On the Data Management Definitions tab you define the data
collection properties.
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Step
4.

Action
Click the Edit Mapping tab. Do the following:
•= In the Configure atom box, select Actual Value and type the PLC address
shown in Figure 3.38.
•= Select High Alarm and associate the relevant alarm text (alarm no. 106),
then select Low Alarm and associate alarm no. 107.

Figure 3.38 On the Edit Mapping tab you type the specific PLC address
and the appropriate alarm numbers.

Section C: Building the Configuration

Step
5.
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Action
Click the Attributes of Bar tab. When you make new selections, the bar
preview to the left changes accordingly. Make the selections as shown in
Figure 3.39.

Figure 3.39 On the Attributes of Bar tab you define the layout of the bar.

6.

Click OK. A small rectangle representing the bar display appears. Position the
bar display inside the water tank and resize it so that it fits within the tank as
shown in Figure 3.40, then position the name and the value.

Figure 3.40 The Overview diagram with the bar display in the right position.
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Define Table Objects
Purpose

In our configuration we need to show the four temperature gauges which measure
temperatures at different levels in the tank. We integrate the four temperature gauges in one
table object, T0147.

To define the
table object
(T0147)

Perform the following steps:
Step
1.

Action
Select Objects → Rectangular Field. The Definition of Object dialogue
appears.
Select Table and type the name and description as shown in Figure 3.41.

Figure 3.41 In the Definition of Object dialogue you type the unique name of
the object and an optional description.

Section C: Building the Configuration

Step
2.

Action
Click OK. The table object properties dialogue appears.
·= In the Type field, select Fixed Table.
·= Type in the names and values shown in Figure 3.42.
·= In the Units drop-down list, select °C.
·= In the Minimum value field, type 0 and in the Maximum value field, type
100.

Figure 3.42 On the Table tab you type the names of the individual
temperature gauges and their initial values.
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Step
3.

Action
Click the Data Management Definitions tab and make the selections shown in
Figure 3.43.
As you can see, the selections differ from the ones for the analog objects as
follows:
•= Logging is set to None which means that historical graphs of the object
values cannot be shown. However, trend graphs can always be displayed,
as they do not depend on logged data.
•= Base interval is set to None which means that there is no data reduction
method and thus no values for the operational reports.
•= In the Scale As field, we have selected the scaling object, Fahren.toCel
which we defined in “Define Scaling Objects”. The scaling object converts
values between 32 and 212 to values between 0 and 100.

Figure 3.43 On the Data Management Definitions tab you define the data
collection properties. Note that we use the Fahren.toCel object to convert the values from °F
to °C.

Section C: Building the Configuration

Step
4.

Action
Click the Display tab.
·= In the State/Value group, check the Units box to show the unit beside the
table values.

Figure 3.44 On the Display tab you define that the values and units are
shown with the table object.
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Step
5.

Action
Click the Edit Mapping tab and type the values shown in Figure 3.45.
As the table object uses the external type FP16, it occupies the addresses
18.00 to 21.00.
NOTE: Although the table object holds four values, you need only give one
address, namely the one for the first value in the table. It is assumed that the
other values in the table are on addresses that follow immediately after the
first one.

Figure 3.45 On the Edit Mapping tab you type the specific PLC address.
Note that you only need to specify one address. IGSS32 assumes that the values have
consecutive addresses.

Section C: Building the Configuration

Step
6.
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Action
Click OK. A small rectangle representing the table object appears.
·= Position the rectangle and resize it to the appropriate size, then place the
name above it and the values inside it.

Figure 3.46 The Overview diagram with the temperature gauges in position.

Define Counter Objects
Purpose

We nearly have a complete configuration now. Only two things are missing:
•= The counter that counts litres in the tank and
•= The text that displays the current status
We will start by defining the counter object, C0147.

To define the
counter object
(C0147)

Perform the following steps:
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Step
1.

Action
Do the following:
•= · Select Objects → Rectangular Field. The Definition of Object dialogue appears.
•= · Select Counter and type the name and description as shown in Figure 3.47.

Figure 3.47 In the Definition of Object dialogue you type the unique name
of the object and an optional description.

2.

Do the following:
·= Click OK. The counter object properties dialogue appears.
·= Type the measuring unit and the values as shown in Figure 3.48.

Figure 3.48 On the Counter tab you specify the measuring unit, the preset
and maximum values and whether you want to enable alarm supervision.
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Step
3.
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Action
Click the Data Management Definitions tab and type the values shown in
Figure 3.49. As you can see, this counter object has neither logging, nor data
reduction or base interval.

Figure 3.49 On the Data Management Definitions tab you define the data
collection properties. Note that there is no logging and base interval.

4.

Click the Display tab.
·= In the State/Value group, check the Units box to show the unit on the
process diagram.
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Step
5.

Action
Click the Edit Mapping tab and type the values shown in Figure 3.50.
NOTE:We use the Word Offset immediately after the table object, that is, 22.

Figure 3.50 On the Edit Mapping tab you type the specific PLC address.
We use the Word Offset immediately after the table object, that is, 22.

Section C: Building the Configuration

Step
6.
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Action
Do the following:
•= · Click OK. A small rectangle representing the counter object appears.
•= · Position the rectangle and resize it to the appropriate size, then place the
name above it and the value inside it.

Figure 3.51 The Overview diagram with the counter object, C0147, in
position.
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Define String Objects
Purpose

The last object we will place on the diagram is the text describing the current state of the
process. For that purpose we will define the string object, Message.

To define the
string object
(Message)

Perform the following steps:
Step
1.

Action
Do the following:
•= · Select Objects → Rectangular Field. The Definition of Object dialogue appears.
•= · Select String and type Message in the Name field
•= · Clear the Name check box and check Value.

Figure 3.52 In the Definition of Object dialogue you type the name of the
string object.

Section C: Building the Configuration

Step
2.

Action
Do the following:
•= · Click OK. The string object properties dialogue appears.
•= · In the Maximum Length field, type 70 and type the initial string shown in
Figure 3.53.

Figure 3.53 On the String tab you type the max. length of the text and
an initial text string.
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Step
3.

Action
Click the Data Management Definitions tab and make the selections shown in
Figure 3.54.

Figure 3.54 On the Data Management Definitions tab you define the data
collection properties. Note that there is a scan interval, but no logging.
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4.
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Action
Click the Edit Mapping tab and type the PLC address as shown in Figure 3.55.
NOTE: We use a new data group for the string object, 21.

Figure 3.55 On the Edit Mapping tab you type the specific PLC address.
We use a new data group for the string object, 21.
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Step
5.

Action
Do the following:
•= · Click OK. A small rectangle representing the string object appears.
•= · Position the rectangle and resize it to the appropriate size, then place the
text string inside it.
RESULT: The configuration is now complete. To allow the operator to open
the Overview diagram automatically, follow the procedure below.

Figure 3.56 The Overview diagram with the string object showing the
current state of the process in position.

To prepare the
diagram for the
operator

Perform the following steps:
Step

Action

1.

Select Format → Set Initial Display to make this diagram open automatically
when Supervise is started.

2.

Select File → Save or press CTRL + S to save the work you have done so far.
NOTE: As in any other program, you should save your work regularly to
avoid losing valuable work and wasting the time to redo it.
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Define Alarm Texts
Introduction

Before we start defining the individual components, we will create the alarm texts to used
in the configuration. We recommend that you plan the alarm texts at an early stage to
ensure consistent use of alarm priorities and colors. Careful planning will also maximize
the reuse of alarm texts.

How the operator
views alarms

One of the things that happens when a component enters a state of alarm during supervision
is that a text describing the alarm situation is shown in the Alarm List. The alarm texts in
the Alarm List are displayed in different colors depending on how critical the alarm
situation is. In the figure below the column Alarm Text shows the user-defined alarm texts.

Figure 3.57 The Alarm List provides the operator with an overview of all active alarms and
gives access to historical alarms in the Alarm Log.
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For our configuration we need the following alarm texts:
Alarm texts for
this configuration
For these components …

Alarm text
properties

we need alarm texts if …

Valves

they are defective.

Flow

the flow is too high, much too high, too low or much too
low, that is, we need four alarm texts.

Level

the level is too high or too low.

We need to create the following alarm texts:
TIP: We recommend that you associate each alarm priority with one color. A consistent
use of colors will ensure that the operator immediately recognizes the importance of an
alarm.
Alarm
no.

Priority

Alarm color

Alarm text

Instructions

101

5

Light red

Valve defective

102

6

Red

Flow exceeds high
alarm

103

5

Light red

Flow exceeds high
limit

104

5

Light red

Flow below low limit

105

6

Red

Flow below low alarm

106

5

Light red

Level too high

The level in the basin is
too high. Open safety valve
...

107

5

Light red

Level too low

The level in the basin is
too low. Pour faster...

NOTE: Fill in the remaining properties as you like. It is recommended to enable Blinking
for alarm color and disable it for acknowledgement color. In that case, the component in
alarm will blink on the process diagram and will stop blinking when the operator
acknowledges the alarm.
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In IGSS32 you can create and edit alarm texts as follows:
Two ways of
defining alarm
texts

To define alarm
texts

•= from the Alarm Details dialogue accessed from the Edit menu
•= from the Edit Alarm Description dialogue accessed from the Edit Mapping tab of the
object properties dialogue
NOTE: The following procedure describes how you define all the above alarm texts from
the Alarm Details dialogue. The alternative is to create the alarm texts as part of the object
definition procedure.
Step
1.

Action
Select Edit → Alarm Details. The Alarm Details dialogue appears.

Figure 3.58 From the Alarm Details dialogue you can create, edit and delete alarm texts
for the current configuration.

2.

Click New to add the first alarm text. The Edit Alarm Description dialogue
appears.

Figure 3.59 On this tab you attach existing alarm texts or create new ones.
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3.

Specify the alarm properties from the table above and fill in the remaining
properties, as you like.

Figure 3.60 The first alarm text is ready for use..

4.

Click OK to save the alarm text and return to the Alarm Details dialogue.

5.

Repeat steps 2 to 4 for the remaining alarm texts.
RESULT: The alarm texts are now ready for use. We will merely have to
associate them with the relevant alarm atoms when we later define the process
components.

6.

Click Close to close the Alarm Details dialogue.

For further details, search for “alarm texts” in the Definition Help file.

Define Graph Windows
Purpose

The configuration is actually complete, but we will also like to see the flow meter, the inlet
valve and the level gauge in a graph window to get a general impression of the state of the
tank T0147. For that purpose we will define the graph object, G0147.

To define the
graph window
(G0147)

Perform the following steps:
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1.
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Action
Do the following:
•= Select Graph → Create. The Definition of New Graph dialogue appears.
•= Enter the name and description shown in Figure 3.61.
•= Select the Name to Menu option to show the graph name in the Graph menu
in Supervise.
•= Select the window elements to be shown on the diagram as shown in Figure
3.61.

Figure 3.61 In the Definition of New Graph dialogue you enter the name and an
optional description and select the window elements you want to show.
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Step
2.

Action
Do the following:
•= Click OK. The Define Graph Parameters dialogue appears.
•= In the Object name column, select the objects shown in Figure 3.62 from
the drop-down lists.
NOTE: Leave the remaining options with the default settings. For further
details, click the
in the upper right hand corner of the dialogue, then click
the item you want information about.

Figure 3.62 In the Define Graph Parameters dialogue you define which process
components you want to show, graph period and layout.
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Step
3.

Action
Do the following:
•= Click OK. The graph window appears.
•= Scale the window to the desired size and position it where you want it to
appear on the operator’s screen.
TIP: If you want to ensure that the graph window always opens in the same
size and position, you can lock these properties by clearing the check box
Allow graph move and resize on the Supervise tab in Setup.

Figure 3.63 The graph window can be scaled and positioned as you like.
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Install the Configuration
Purpose

The configuration is now ready for installation. Let us install it and correct any installation
errors, if required.

To install the
configuration

Perform the following steps:
Step

Action

1.

Select File → Install Configuration or press CTRL + T. The Installation
Options dialogue appears.

2.

Do the following:
•= In the Show group, check all the boxes to display this information in the
installation report.
•= In the Keep group, check the Alarm files and Log files boxes to preserve
the data in the currently used alarm and log files.

Figure 3.65 The Installation Options dialogue allows you to control the
contents of the installation report, <MyConfig>.prt and various other settings.

TIP: Check the Skip This Dialog box to install without seeing this dialogue in
future. To show the dialogue again, hold down SHIFT while you select Install
Configuration in the File menu.
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Step
3.
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Action
The installation program is automatically launched and checks the entire
configuration.
·= If the installation is successful, a message prompt appears informing you of
how many objects the installed configuration holds. From the message
prompt, you can access the installation report, <MyConfig>.prt by clicking
Yes.
·= If there are any errors in the configuration, the error log file,
<MyConfig>.err, appears automatically. By using the information supplied
in this file, you can easily correct any errors and then repeat the
installation.

4.

To run the configuration in Supervise, select Start → Programs → IGSS32 3.0
The IGSS32 Starter dialogue appears.

→ IGSS32 Starter.

5.

The installation
report

Click the Supervise button to start the configuration in Supervise.

When a configuration is successfully installed, a dialogue appears allowing you to view the
installation report, <MyConfig>.prt. The report contains detailed information about the
configuration, for example, scan intervals, base intervals, communication efficiency.
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Figure 3.66 The installation report contains detailed information about the configuration.

Towards the end of the installation report, important information about the efficiency of the
communication with the PLC is included as shown in Figure 3.67.
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Figure 3.67 The installation report includes information about the efficiency
of the communication with the PLC.

For further details about the installation report, search for “installation report” in the
Definition Help file.
To correct
Error log file
installation errors

NOTE: If your installation is not successful, the error log file, <MyConfig>.err,
automatically appears. Errors are clearly marked with “***” allowing you to easily find the
erroneous objects in the configuration and correct the errors.
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Figure 3.68 The error log file, <MyConfig>.err, clearly marks the errors found during
installation allowing you to quickly find the erroneous objects and correct the errors.

To correct installation errors
Perform the following steps:
Step

Action

1.

Note down the errors from the error log file or print the file and mark up the
errors.

2.

In Definition correct the errors using the information from the error log file.
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Action

3.

Repeat step 2 for all errors found.

4.

Install the configuration again (see “To install the configuration” above).

5.

If there are still any errors, repeat this procedure until all errors are
eliminated.
NOTE: You cannot start a configuration before all errors are corrected.

For details about installing configurations, search for “installing” in the Help function for
Definition.

Simulate Process Values
Purpose

Now that we have all the objects in our configuration, we would like to simulate real
process values and alarms to see how the operator will view the process diagram in
Supervise. At the same time, we can visually check whether our diagram layout works
when the process “comes alive”.
In order to view simulated values in Supervise, you need to do the following:

Using *.sim files

•= create a simulation data file, <MyConfig>.sim
•= check that the Run Simulated option is enabled on the DC tab in Setup
To create a *.sim
file

Perform the following steps:
Step
1.

Action
Open a text editor, for example, Notepad.
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2.

Type the text as shown in Error! Reference source not found..
TIP: For analog objects you can use an increment value which will either
increase or decrease the current value.

Figure 3.69 An example of a *.sim file. Note that you can specify multiple
values for each object. The data collection engine reads the file cyclically from start to
end.

3.

Save the file in the configuration root folder as Getting Started.sim.

For details about simulation file syntax, search for “simulating” in the Definition Help file.
To simulate
process values

Perform the following steps:
Step
1.

Action
Check that the data collection engine runs simulated as follows:
•= · Select Start → Programs → IGSS32 3.0 → Setup.
•= · Click the DC tab and check the Run Simulated box.

2.

Install the configuration in Definition (see “Install the Configuration”
below).
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Action

3.

Select Start → Programs → IGSS32 3.0 → IGSS32 Starter. The IGSS32 Starter
dialogue appears.

4.

Click the Supervise button.
RESULT: Supervise is automatically launched and the simulation data from
the *.sim file is used to show process values. If there are any syntax errors,
they will be reported as soon as the data collection engine (DC) starts.

Define Operator Reports
Purpose

The final thing we need to do is to create the operational reports which the operator will be
able to access from Supervise.

Reporting
workflow

When you define new reports, you go through the following phases:
•= create a report format
•= create the object groups (report headings)
•= include the objects in the reports
•= test the reports
•= make the reports accessible in Supervise

Report types

IGSS32 includes the following standard report types:
•= Periodical reports (daily, weekly, monthly, quarterly and yearly)
•= Snapshot reports (current process values)
•= Alarm statistics

Event Report
Writer (ERW)

Besides the standard reports, you can create customized reports using ERW in conjunction
with MS Excel 2000. For further details refer to the ERW Help file.

To create a report In this example, we will create a report format to be used for periodical reports (daily,
format
weekly, etc.). Perform the following steps:

Step
1.

Action
Select Start → Programs → IGSS32 3.0 → Report Formats. The Report
Formats dialogue appears.
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2.

Do the following:
·= Select the default report format called Rformat.
·= Type the name DemoRep in the Report format box.
·= Check Set as default to automatically suggest this report format when the
operator requests a report.
·= Click the Use in periodical option to allow the operator to base daily,
weekly, monthly, quarterly and yearly reports on this format.
·= Click Update Hist. Data to update the format with information about the
objects in the active configuration which use a data reduction method and
thus can be used in the periodical reports.

Figure 3.71 From this dialogue you create and maintain the report formats
on which operator reports are based. A report format can be divided into sections
(Object Groups).

3.

Click the Object Groups button. The Object Groups dialogue appears.
•= ·Click Add Group. A new group number appears. Select that number.
•= ·Type Flow and level in the Name box

Section C: Building the Configuration

4.
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•= · Repeat step 3 for the other groups as shown in .
TIP:
no.

To change the sequence of report groups, type an appropriate Serial
for each group. By default, groups are sorted alphabetically.

Figure 3.73 In this dialogue you specify the names of the sections
you want in the report.

5.

Click Close to return to the Report Formats dialogue.

6.

In the Report Formats dialogue, click Select Objects. The Select Report
Objects dialogue appears.
•= Click each object in the list and select the relevant report group in the
Group drop-down list. You can select multiple objects in the list, if
required. In that case, click Apply to save changes for multiple objects.
Object name

Object group

F0147

Flow and level

L0147

Flow and level

C0147

Miscellaneous

T0147

Miscellaneous

V1

Valves

V2

Valves
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7.

Do the following:
•= Select the above objects in the list by holding down CTRL while you click
each object.
•= Check the following boxes: Include, Total, Std. Dev. and Reduced.
•= Click Apply to save the changes.
RESULT: The report format is now ready for use. But we still need provide
direct access to the report programs for the operator (see “To include reports
as user programs”).

Figure 3.75 In this dialogue you include the individual objects in the report
and specify the report group or heading to which the object belongs.

7.

Click Close to return to the Report Formats dialogue.

8.

Click Exit to quit the program.

To include reports The operator needs direct access to this report format, so we will include links to the report
as user programs programs in the User Programs menu of Supervise.

NOTE: By default, the installation program adds links to the Periodical Reports program
and the Snapshot Reports program. The procedure below describes how you do this
manually.
Perform the following steps:
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1.
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Action
In Definition, select User Programs → Customize. The User Programs
dialogue appears.
•= ·=Click New, then type Dmyrep.mde which is the file name of the
Periodical Reports program. Click OK.
NOTE: During installation, the installation path of IGSS becomes part of the
Windows PATH environment variable. This means that you do not need to
specify the full path.
•= · In the Menu Text box, type Periodical Reports.
•= · Repeat for snapshot reports. This time type the file name,
Actrep.mde.
•= · Click Close.
•= · Install the configuration (see “Install the configuration” in this section).

Figure 3.76 In this dialogue you specify the paths and names of the programs
you want to include in the User Programs menu of Supervise.
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2.

Verify the results in Supervise as follows:
·= Select Start → Programs → IGSS32 3.0 → IGSS32 Starter.
·= Click Supervise.
·= Select User Programs → Periodical Reports. The Periodical Reports
dialogue appears.

Figure 3.77 In this dialogue the operator selects the appropriate report type
and report date and selects either an overview report or a detailed report.

Automatic
If you want to print reports at regular intervals, we recommend using the Job Scheduler
printing of reports program (Jobsch.exe in the [Install Path]\Gss subfolder. It allows you to start any program

at a specified time. You may want to print a daily report every morning at 7:00 a.m. This is
easily done using Job Scheduler.
For details about automatic printing, refer to the Job Scheduler Help file.
For details about reports, refer to the Report Help file.
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147

Section D: Refining the Configuration
Overview
About this section This section describes some of the advanced features in IGSS32. To allow you to get

acquainted with these facilities, we refine the configuration we have just built by using:
•= The Drawing toolbar
•= Standard descriptors (drawing objects, Windows controls, etc.)
•= The Library toolbar
Contents
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Using Advanced Features in IGSS32
Introduction

In this section we will try out some of the advanced features in IGSS32. These features
allow us to present process components in completely new ways, for example, by using
standard Windows controls.

Drawing toolbar

In older versions of IGSS, a background picture from an external drawing program was
used, but now you can simply use a background color and draw the process from scratch
using the Drawing toolbar and other features known from drawing programs.
The figure below shows the functions of the individual buttons of the Drawing toolbar.
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Figure 3.73 The Drawing toolbar allows you to create drawing objects and place graphics
files and ActiveX/OLE objects on the process diagram.

The components you create using the Drawing toolbar can either be static or connected to
an IGSS object. In the latter case, the appearance of, for example, a drawing object is
linked to the state or value of the process component.
For details about the Drawing toolbar, search for “toolbars; Drawing toolbar” in the
Definition Help file.
Standard
descriptors

The most typical way of showing IGSS objects on a process diagram is to use the symbols
from the built-in symbol file, Symbols.v12. However, a number of additional ways of
displaying objects are also available.
•= Drawing objects (line, polygon, etc.)
•= Windows controls (button, combo box, etc.)
•= Graphics files (*.bmp, *.wmf, *.emf, *.gif, etc.)
•= Multimedia files (*.avi and *.gif)
•= OLE objects
•= ActiveX controls
When you use a standard descriptor to represent an IGSS object, you can link its
appearance to the state or value of the object.
For details about standard descriptors, search for “standard descriptors” in the Definition
Help file.

Library toolbar

The Library toolbar allows you to drag and drop your favourite graphics objects onto
process diagrams.
The figure below shows the functionality of the toolbar.
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Figure 3.74 Place your favourite graphics files on the Library toolbar and drag and drop
them onto process diagrams.

For details about the Library toolbar, search for “Library toolbar” in the Definition Help
file.
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Use Lines for Analog Objects
Purpose

Instead of using a standard symbol from the symbol file for the flow meter, F0147, you may
want to use a line instead. The line could be placed on top of the inlet pipe to make it
evident for the operator that an alarm on this object is directly related to the inlet pipe.
We will apply different colors for the alarm ranges and enable line flashing when the object
is in alarm.

To use a line for
the flow meter,
F0147

NOTE: Before we start using the advanced features, we will create a new diagram,
Overview_New. Create the new diagram as described in “Create Areas and Diagrams” in
Section C.
Step
1.

Action
Select Objects → Standard Descriptors → Line. The Definition of Object
dialogue appears.
•= · Select Analog and check Value.
•= · In the Name drop-down list, select F0147.
•= · Click OK and the line representing the object appears.

Figure 3.75 The usual Definition of Object dialogue appears when you
connect a standard descriptor to an IGSS object.
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Position the line as shown in Figure 3.76, then position the name and the
value.

Figure 3.76 Position the line on top of the inlet pipe.

3.

Double-click the line to define its properties. Click the Attributes of Line tab.
•= In the Line Color group, double-click the Bind Line Color property to
enable it.
•= Double-click each of the color bars to choose the appropriate colors for
the individual atoms (alarm limits).

Figure 3.77 In the Line Color group, you link the color of the line to the
actual process value. You can specify individual colors for the different alarm ranges.
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4.

Do the following:
•= In the Bindings to Object Alarms group, double-click Flash Line to enable
line flashing when the object is in alarm.
•= Double-click each of the color bars to choose the appropriate colors.

Figure 3.78 In the Bindings to Object Alarms group, you enable line
flashing when the object is in alarm and choose the appropriate colors.

5.

Click OK.
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Use Polygons for Analog Objects
Purpose

If you have a tank with a non-square form, you may want to use a polygon to represent the
level of the tank contents. In this example, we will use the existing object, L0147. We will
make the background of the polygon flash when the process value exceeds one of the alarm
limits.
This time we will use the Drawing toolbar to create the polygon and then later connect its
appearance to L0147.

To use a polygon
for an analog
object

Perform the following steps:
Step
1.
2.
3.

Action
If the Drawing toolbar is not visible, select View → Drawing toolbar.
Click

to activate the polygon-drawing tool.

Do the following:
·= Click once where you want the top left corner of the polygon and draw the
first vertical line.
·= Click once where you want the first line to end.
·= Repeat for all lines until you have the shape shown in Figure 3.79.
·= Double-click on the border when you have completed the polygon.

Figure 3.79 The polygon representing the tank is now drawn, ready to be
connected to the appropriate IGSS object.
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4.

Right-click the polygon and select Connect. The Definition of Object dialogue
appears.
•= · Select Analog and check Value.
•= · In the Name drop-down list, select L0147.

Figure 3.80 The usual Definition of Object dialogue appears when you
connect a standard descriptor to an IGSS object.

5.

Click OK. The object properties dialogue appears.
Click OK again, as we do not want to change any properties. The object name
and value appear. Position them as shown in Figure 3.84.

6.

Double-click the polygon and select the Attributes of Polygon tab.
•= In the Background Color group, double-click the Bind Background Color
property to enable it.
•= Double-click each of the color bars and choose the appropriate colors.

Figure 3.81 In the Background Color group, you enable background
flashing and choose the appropriate colors.
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Do the following:
•= In the Bindings to Object Alarms group, double-click the Flashing
Background property to enable background flashing when the object is in
alarm.
•= Double-click the Flash Background On Color bar and choose the
appropriate color.

Figure 3.82 In the Bindings to Object Alarms group, you enable
background flashing when the object enters the alarm state and choose the appropriate
colors.
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8.

Do the following:
·= In the Miscellaneous group, double-click each of the two color bars to
choose the fill color and pattern.
·= Double-click Fill Direction and select Up.
·= Double-click Fill Criteria and select Actual Value.
·= Double-click Fill Active to enable filling of the polygon according to the
process value.

Figure 3.83 In the Miscellaneous group, you select the fill color and pattern
and the fill criteria, for example, Actual Value to show the process value. These
properties determine the filling of the polygon.

Section D: Refining the Configuration

9.

Click OK. The polygon should now look like this.

Figure 3.84 The polygon is positioned and the filling reflects the current
process value.
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Refine Bar Displays
Purpose

When we defined the object representing the water level in the tank, L0147, we defined a
standard bar display. We will now customize the display using some of the numerous
layout features available.

To define a bar
display
(advanced)

Perform the following steps:
Step
1.

Action
Select Objects → Bar Display. The Definition of Object dialogue appears.
•= Select Analog and check Value.
•= In the Name list, select L0147 and click OK. The Attributes of Bar tab
appears.

Figure 3.85 The usual Definition of Object dialogue appears when we
define a new bar display. In this case, we choose the existing analog object, L0147.
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Do the following:
•= In the Limits group, select Limit Lines to show the alarm limits.
•= In the Colors and Patterns group, click Limit and select a red color for the
alarm limit line.
•= In the Align Axis group, select Left to show the value axis to the left of the
tank.
•= In the Bar View group, select 2-D View to show the bar two-dimensionally.
•= In the Scale Attributes group, check Show Scale and Show Values.
•= Click OK. The bar display appears.

Figure 3.86 The layout properties of the bar display have been entered. Use
the bar preview to verify your selections.
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3.

Move the bar display over the tank and resize it so that it fits within the tank
as shown in Figure 3.87, then position the name and the value.

Figure 3.87 The bar display is positioned. Notice the two alarm limit lines
which clearly alert the operator if the water level is nearing an alarm level.
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Use Command Buttons for Counter Objects
Purpose

The counter object, C0147, that counts the number of litres let into the tank per hour was
initially defined as a rectangular field. By using a command button instead, we allow the
operator to insert, for example, the preset value simply by clicking the button.

To use a
command button
for a counter
object

Perform the following steps:
Step
1.

Action
Select Objects → Standard Descriptors → Button Control. The Definition of
Object dialogue appears.
•= Select Counter and check Value.
•= In the Name drop-down list, select C0147.
•= Click OK. The command button appears.

Figure 3.88 The usual Definition of Object dialogue appears when we use
a command button to represent an IGSS object.

2.

Move the command button, the name and the value to the position shown in
Figure 3.90 and resize the button, as required.
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3.

Double-click the button and select the Attributes of Button tab.
•= In the Command On Click group, double-click the Bind Command On
Click property and double-click the Preset property to enable the operator
to issue this command by clicking the button.
•= In the Miscellaneous group, double-click the Text to be displayed
property and type Preset in the ensuing dialogue and click OK.

Figure 3.89 In the Button Click group, you bind the button to one of the
four counter commands the operator can issue.

4.

Click OK. The counter object should now look like this.

Figure 3.90 The command button representing the counter object is
complete. The operator can issue the Preset command just by clicking the button.
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Use Command Fields or Combo Boxes for Digital Objects
Purpose

The two valves, V1 and V2, were initially defined using standard valve symbols from the
symbol file. IGSS32 provides two useful alternatives, a command field or a combo box.

To define a digital Perform the following steps:
object as a
command field
Step
Action
(V1)

1.

Select Objects → Command Field. The Definition of Object dialogue appears.
•= In the Name drop-down list, select V1 and uncheck Value.

Figure 3.91 The usual Definition of Object dialogue appears when we
define a command field.
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2.

Do the following:
•= Click OK. The Set Command Layout tab appears.
•= Check all four boxes to the right of the preview.
•= In the Align group, select Horizontal.

Figure 3.92 On the Set Command Layout tab, you define the graphical
display of the command field. Notice that you can show both commands and current
state.

3.

Do the following:
•= Click OK. The command field appears.
•= Position and resize the field as shown in Figure 3.93, then position the
name.

Figure 3.93 The command field is positioned. Notice that the operator can
instantly view the available commands and the current state.
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Perform the following steps:
To define digital
objects as combo
boxes (V2)
Step
Action
1.

Select Objects → Standard Descriptors → Combo Control. The Definition of
Object dialogue appears.
•= In the Name drop-down list, select V2 and click OK. The combo box
appears.

Figure 3.94

2.

The usual Definition of Object dialogue appears when we
define a combo box.

Position and resize the combo box as shown in Figure 3.95, then position the
name and the state.
TIP: To allow both commands to be shown in the drop-down list, extend the
combo box area downwards. Click on the combo box and position the cursor
over the centre handle in the bottom. When the hand appears, resize as
required.

Figure 3.95 The combo box representing V2 is positioned. The operator
selects the appropriate command by opening the drop-down list and selecting the
command.
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Place Your Favourite Graphics in the Library Toolbar
Purpose

Let us imagine that you are creating a configuration for a plant that has numerous identical
tanks, but they are placed on different process diagrams. The tank is drawn in an external
drawing program, but instead of using the copy/paste function, we will place the graphic on
the Library toolbar.

To use the Library Perform the following steps:
toolbar

Step

Action

1.

Draw the tank in your favourite drawing program and export it or save it in
one of the supported graphics formats.

2.

Select View → Library Toolbar to show the toolbar.

3.

Do the following:
•= Right-click the toolbar and select Add New Tool in the popup menu.
•= Select the graphic you created in step 1 and click OK. The graphic appears
on the toolbar.

Figure 3.96 In this dialogue you select the graphic you want to place on the Library
toolbar. Check the Show Preview box to view the graphic.

4.

Do the following:
•= Right-click the graphic in the toolbar and select Edit Tool Name in the
popup menu.
•= Type Tank 1 in the ensuing dialogue and click OK.

Figure 3.97 In this dialogue you type the name you want to show along with the
graphic thumbnail on the Library toolbar.
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5.

Click the graphic in the toolbar and drag it onto the process diagram.

Figure 3.98 The tank has been dragged from the Library toolbar onto the process
diagram. The tank can be reused any number of times you like.

6.

Repeat this procedure on all diagrams where you need the tank.
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Term/abbreviation

Definition

actual value

The actual value is the current process value of an analog
object.

alarm

An alarm is a notification which is generated when an
error situation occurs, for example, when a value falls
below or exceeds a certain limit.

alarm acknowledgement
indicator

The alarm acknowledgement indicator is a specific bit
indicating that an alarm has been acknowledged. The
alarm acknowledgement indicator bit is defined as part of
the digital template.

alarm delay

The alarm delay is a time delay specifying how long an
alarm must exist before being registered as such. The
default alarm delay is specified from the Setup program.

alarm icon

The alarm icon shows the total number of active alarms
and the color of the alarm with the highest priority.
Double-clicking the alarm icon will open the Alarm List.
The alarm icon is also shown in the Windows Taskbar.

alarm indicator

An alarm indicator is a specific bit defined to indicate
incoming alarms from a digital object. The alarm indicator
bit is defined as part of a digital template.

Alarm List

The Alarm List shows a list of active alarms. In the Alarm
List the operator can view historical alarms (Alarm Log)
and print alarm statistics reports.

alarm priority

The alarm priority describes the seriousness of the alarm.
The priority is a value within the range from 255 (highest
priority) to 1 (lowest priority). Each alarm priority should
be associated with a specific color.
We recommend that you carefully plan the number of
alarm priorities and their associated colors to avoid any
confusion for the operators.

alarm text

An alarm text is a general description of an error situation,
for example, "motor overheated". An alarm text consists
of the following components: an alarm number, an alarm
priority, a short alarm text and the operator instructions.
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A number of additional properties can be set, including
sound and events to occur when the alarm arises.
analog object

An analog object is a process component that can take on
any value within a specified range. Typical examples of
analog objects are flow meters, level and temperature
gauges.

area

An area is a collection of diagrams, graphs and process
components that belong together. Areas may be used to
reflect the division of a plant into different sections or
production lines. If a plant cannot be seen as divided into
different sections, the system designer may use only one
area.
When you define an IGSS object, you specify which area
of the configuration it belongs to. However, one area is
special because all objects defined here are automatically
known in all other areas. This area is called ‘Global’ and
is automatically created in every IGSS configuration. Do
not rename or remove the Global area.

atom

An atom corresponds to a potential PLC address.
As an example an analog object has 6 atoms attached, i.e.
6 entities that might have an address in the PLC: high
alarm, high limit, actual value, set point, low limit and low
alarm.

background picture

A background picture is a drawing used as the static
background for a process diagram.
As an alternative, you can also use a background color
and create the diagram from scratch using the built-in
drawing tools.

bar display

A bar display shows the value of analog or table objects in
a bar graph. A typical example of use is to show the water
level in a tank.

base interval

The base interval determines how often the system
reduces the scanned values read from the PLC to one data
reduction value, for example, average. See also "data
reduction".

bit offset

A bit offset is a number (or text) identifying the precise bit
within the word of the data group. The bit offset is defined
as part of the PLC address.
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bitmap file (BMP)

A bitmap file is a graphic saved in the *.bmp format. It
can be used as the background picture of a diagram, as an
independent graphic or to represent an IGSS object.

click-sensitive area

A click-sensitive area is a field on a diagram on which the
operator can click to open an IGSS object. A clicksensitive area is defined as a rectangular field in IGSS. A
typical example is to use rectangular fields on an overview
diagram where the operator simply clicks on the field to
open the relevant sub-diagrams.

command

A command is a named command that the operator can
issue to control a digital object. For example, an "open"
command to open a valve and a "close" command to close
it. Command names are defined as part of the digital
template.

configuration

A configuration is a model of an actual process being
monitored and controlled; the process may be anything
from a purification plant to a luxury liner or a production
line.
A configuration consists of a number of process diagrams
with dynamic representations of the process components
(the valves, motors, flow meters, etc.) that the operator
can control from his screen.

context-sensitive Help

Context-sensitive Help is a Help text describing the
specific user interface object from which you requested
help. In dialogues, context-sensitive Help is called What's
This Help.

counter object

A counter object is a process component that can take on
any value up to a given maximum limit. Typically a
counter object is used to visualise a PLC counter, for
example, one that counts the hours of operation of a
motor.

data collection (DC)

The data collection engine (DC) is the heart of IGSS. DC
collects data from the process and sends data back to the
process, for example, if the operator issues a command to
stop a pump. DC also writes data to the .log, .bcl and .alm
data files and distributes data to the operator stations in a
multi-user system.
In the Setup program, you can control various data
collection settings.

data group

A data group is a number (or text) identifying a section of
the memory layout of the PLC which consists of a number
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of units or blocks of words (16 bit each) numbered from 0
to 256. The data group is specified as part of the PLC
address.
data reduction

Data reduction defines the method used to reduce the
scanned process values to one data reduction value, for
example, average. The scan interval defines the interval
between the individual readings of the process values and
the base interval defines the interval between the
individual reductions.

diagram

A process diagram is a graphical view of a process or part
of a process. A diagram typically consists of a static and a
dynamic part. The static part comprises the process pipes,
the tanks, etc. while the dynamic part shows the contents
of the tank, the valves, the motors, etc. that change state or
value.
A diagram may be opened from the Diagram menu, from a
click-sensitive area, from a symbol or using a function
key.

digital object

A digital object is a process component that has a finite
number of states and commands. Typically, such a
component would be a valve which can be open or closed
or a motor which can be stopped or run at quarter speed,
half speed or full speed.

driver

A driver is a control program enabling IGSS to
communicate with the PLC which collects the data from
the process. 7-Technologies has developed a wide range
of type-specific drivers, but you can also use a generic
driver based on the OPC (OLE for Process Control)
standard.

driver profile (Driver Setup)

A driver profile is a set of max. 4 communication drivers
set up for a specific IGSS configuration. The driver
profile is defined in Driver Setup and will be activated
when the operator starts the configuration.

enhanced metafile (EMF)

An enhanced metafile is a graphic saved in the *.emf
format. It can be used as the background picture of a
diagram, as an independent graphic or to represent an
IGSS object.

external type

The external type identifies the data type used in the PLC
to represent the process value. When IGSS knows this
format, it automatically converts the value to normal
integers.
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The available data types are driver-specific and can be
enabled or disabled in Driver Setup.
Examples of external types are: FP8 (fixed point 8 bit),
FP16 (fixed point 16 bit) and FP32 (fixed point 32 bit).
function key

A function key is one of the F-keys on the keyboard. In
IGSS you can assign frequently used operations to
function keys. Function keys are defined as part of the
diagram properties, for example, F2 to start the pump and
F3 to stop it. Up to 24 function keys can be defined for
each diagram. Additionally, 24 global function keys can
be defined. A prefix key is used to activate function keys
13 - 24.

Global area

The Global area is a special area. All objects defined in
this area are automatically known in all areas. The Global
area is automatically created in an IGSS configuration. Do
not rename or remove this area.
We recommend that you define templates and scaling
objects in the Global area to make them globally available
in the configuration.

global parameter

A global parameter defines a global setting for IGSS, for
example, data management and data collection settings.
The global parameters are configured in the Setup
program.

graph

A graph is a graphical chart showing the values or states
of up to five process components. The source data can be
either scanned values (*.log files) or historical values
(*.bcl files).

grid

A grid consists of two sets of lines that crisscross at right
angles. On a diagram there is an invisible grid of
horizontal and vertical dots. In IGSS you can set the grid
size (in mm) and snap objects to that grid to easily align
objects.

I/O mode

The I/O mode defines whether the value is read from (in)
or written (out) to a PLC address or both (in/out). Some
values can be set to "local" if they are generated within
IGSS. This is typically used for alarm limits on analog
objects. IGSS detects when the process value exceeds the
specified alarm limits and generates an alarm.
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I/O value (scaling object)

The I/O value is a value that IGSS can convert to another
value (see "real value"), for example, to convert from one
measuring unit to another.

IGSS

Interactive Graphical Supervisory System

IGSS object

An IGSS object is an object of one of the nine IGSS
object types: area, diagram, graph, analog, digital, table,
counter, scaling, string.

initial display

The initial display is the first diagram which opens when
the operator starts IGSS. The system designer chooses the
initial diagram in the Definition program. Each area has
its own initial display.

Keep Window option

The Keep Window option ensures that a particular
diagram is always kept open. During supervision five
diagrams may be open simultaneously. When diagram
number six is opened, the first one closes unless you have
enabled the Keep Window option. The option is diagram
property.

local

Local is the I/O mode used for atoms which are generated
locally within IGSS, for example, an alarm which is
generated when the alarm limit is exceeded.

logging

Logging means to save process values in a log file (.log).
Besides the process values, you can also log operator
commands (logging out).
If you only want to log more significant value
fluctuations, you can determine that the value must change
with a certain percentage before it is logged. You may, for
example, define that a flow value must change with more
than 5 % in order to be logged.
Log data can be used as the data source of graphs.

node

A node is a unique number identifying the PLC in a
network. The node number is defined in the Driver Setup
program.
When you define an object in Definition, the node
numbers defined in Driver Setup can be selected as part of
the PLC address.
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object caption

An object caption is the text describing the object. The
object caption may include the name and description of
the object and its current process value or state. What you
want to show in the object caption is defined on the
"Display" tab of the object properties dialogue.

OLE Linking and Embedding
(OLE)

OLE is a standard used for linking or embedding
components made in third party programs into IGSS. You
can, for example, define an OLE-embedded diagram that
link to a MS Excel worksheet that the operators need
during supervision. Note that the functions of the OLE
server application become available as soon as you
activate such a diagram.

preset value

The preset value is a value that the operator can issue for a
counter object with the Preset command from the
Supervise program.

process component

A process component is a physical process component in
the plant, for example, a motor, a pump, a valve, etc.

properties

The properties are the attributes or characteristics of an
object. The object properties are defined and edited from
a dialogue containing all object properties. For example,
to edit the properties of an analog object, simply doubleclick the object symbol and edit the properties as required.

Protect object

The Protect object is automatically included in every
IGSS configuration you create. It is used to protect IGSS
objects from unauthorized use. By connecting the Protect
object to an IGSS object, you can control what the
operator is allowed to do with this object. The user
privileges are set up in the User Administration program.
Example: By connecting the Protect object to an analog
object and by setting up the necessary parameters in the
User Administration program, you can allow some
operators to change the set point for the object and other
operators will not be able to do it.

PROTECT template

The PROTECT template is a built-in template defining
protection levels. By default, one object called "Protect"
is based on this template and will be included in every
IGSS configuration you create. If required, you can create
additional "Protect" objects based on this template.

real value (scaling object)

The real value is the value you want to use instead of the
I/O value, see "I/O value (scaling object)", for example, to
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convert from one measuring unit to another.
reference

A reference is a link to an existing IGSS object. A
reference is typically used to show an already existing
object on another diagram. If you copy an IGSS object,
you can paste it as a new object or as a reference.

scaling object

A scaling object is an internal object used to map values
from one range to values within another range, for
example, to convert values from one measuring unit to
another. A scaling object is used to scale analog or table
object values.

scan interval

The scan interval defines how often the component
address in the PLC is scanned. The interval is defined on
the Data Management Definitions tab of the object
properties dialogue.
Four different scan intervals can be selected in Definition.
They are defined in the Setup program.

set point

The set point is the desired process value to which the
process value is calibrated. The set point is defined as part
of an analog object. The set point value can be changed by
the operator during supervision.

simulate

To simulate data means to make IGSS use simulated
process values in the configuration. This enables the
system designer to simulate how the operator will view the
process during supervision and to visually check the
diagram layout when the process "comes alive".
The data collection engine (DC) must run simulated, if
you want to use simulated data.

snap (to grid)

Snap to grid means to align an object to the invisible grid
of a diagram. This function is used to align objects neatly
on a process diagram.

state

A state is a particular state that a digital object can enter.
A valve may, for example, enter an "open" or a "closed"
state. The operator can force a digital object into another
state by issuing a command.

state indicator

A state indicator is a specific bit representing the state of a
digital object. The state indicator bit is defined as part of
the digital template.

status bar

The status bar is the area at the bottom of a window
showing the current status or giving other information,
such as the meaning of a particular command.
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Note that the diagram status bar contains key information
about a selected IGSS object, cursor co-ordinates, etc.
string object

A string object is a text field displaying a message related
to the monitored process, typically describing that a part
of the PLC program is operative. An example: "Water is
now being filled into basin ..."

symbol

A symbol is a graphic used to represent a process
component, for example, a valve. Symbols are clicksensitive and during supervision open dialogues where the
operator can set parameters like alarm limits or issue
commands like ‘close’.
A standard symbol file (Symbols.v12) containing the
industry standard symbols is supplied with the system.
Symbols are pixel-based and can be created or modified in
the Symbol Editor program.

symbol file

The symbol file is a library of symbols. IGSS comes with
the default symbol file, Symbols.v12.

symbol table

A symbol table is a collection of symbols for a specific
type of component. A symbol table may, for example,
contain symbols for valves. A symbol file contains a
number of symbol tables. The names of the symbol tables
in the active symbol file are shown in the lower portion of
the Objects menu in Definition.

tab

A tab is a "page" of a dialogue similar to the index tabs of
a card file. A tab is accessed by clicking one of the tab
names at the top of the dialogue. Each tab contains a
collection of properties, for example, data management
properties.

table object

A table object, like the analog object, is used to represent
a process component that can take on any value within a
specified range. However, a single table object may be
used for up to ten different analog objects that belong
together in some way, for example, temperature gauges at
different locations within a tank.

template

A template is a user-defined template - based on one of
the IGSS types - that you should create when a number of
process components are very similar and share several
properties. The real process components are then based on
this template eliminating the repetitive task of entering the
same information for each component.
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Templates may be defined for the following IGSS types:
analog, table, counter and digital.
type

An IGSS type is a built-in template that ensures that you
provide all the necessary information about each process
component you define.
There are nine IGSS types: area, diagram, graph, analog,
table, counter, digital, string and scaling. Area, diagram
and graph are non-process objects. The remaining object
types represent process components, except the scaling
object which is an internal IGSS object used for
conversion purposes.

UTC

Coordinated Universal Time (formerly Greenwich Mean
Time), used as the basis for calculating time in most parts
of the world.
IGSS uses this time format internally. You can switch
between UTC and local time by enabling or disabling
"UTC Date/Time" in the "View" menu.

What's This? Help

What's This? Help is a Help text describing a specific item
in a dialogue. To view What's This? Help, simply click
the "?" in the upper right corner of the dialogue, then click
the item you want information about.

window element

A window element is a part of a window in the Windows
environment. Window elements include the minimize and
maximize buttons, the status bar, the title bar, etc. These
elements can be shown or hidden in diagram and graph
windows.

Windows metafile (WMF)

A Windows metafile is a graphic saved in the *.wmf
format. It can be used as the background picture of a
diagram, as an independent graphic or to represent an
IGSS object.

WinPager

WinPager is an add-on utility used to route alarm
messages to personal pagers, mobile phones, e-mail
accounts or telefaxes.
In WinPager, you set up duty schedules which define the
periods where you want WinPager to handle alarms. This
would typically be evenings or weekends.
Also, WinPager allows for remote acknowledgement of

Glossary

179

IGSS alarms by using a touch-tone telephone.
word offset

The word offset is a number (or text) identifying the
precise word within the data group. The word offset is one
of the components of a PLC address.
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